Android Freeze

I'm using an Android phone and select "On Now", then I pick any channel, then WATCH.
I'm connected via local WiFi which speed tests at 99 Mips.
The show plays for about 60 seconds and then the screen freezes and never unfreezes.
I have the speed set to 720P 4Mbps.
I'm running a Galaxy S5 with Android 6.01 (rooted).
Any idea what I can look at?

Streaming Quality should be set to Original if you're at home.

Are you able to leave the player and submit diagnostics, or is the whole app crashed?

Additional information: When I play a recording, there was no problem.

I am testing "Original" option now. It has not locked up in the first 3 minutes..
The app does not crash, but I don't now how to submit diagnostics from the Android.

The "Original" setting seems to have fixed it, But I don't see why you can't elect to use less bandwidth.


TVE is already lower bandwidth than any OTA stream. Reducing the bitrate even further requires transcoding the signal... which places additional demands on the CPU in your DVR. Your limitation is an issue caused by your own DVR hardware.

You can try updating the DVR to the latest pre-release which has some transcoder improvements. To update, click and hold the Check For Update button.

When you select a lower quality, the video has to go through your DVR PC and get re-compressed into the smaller file before being sent to your phone. There's more pieces involves and more opportunities for failure.

I had a failure using cell data stream at 0.7 Mbps. I then upgraded to the new version and the problem went away. I guess I should be thinking about a faster computer.

Thanks for the fix.


Hmmm... I have the opposite problem on my OnePlus 3T. I have a 125mbps connection to server and using "original" quality setting. Show appears to load okay at first, but freezes before a screen appears and the app hangs.

If I select lower quality (to anything it appears) the CPU on my Synology NAS (Intel Celeron J3455) spikes to ~60% and video plays, but stutters badly.

Please make sure your NAS is set to Hardware deinterlacing on the DVR web UI and then it should play correctly at lower qualities. Original is not suitable for internet streaming.

I made that change, and now I can stream to my phone (at home) at any lower setting (including 1080p 8Mbps). However original still hangs the app.

I tested the app on my Chromebook though and it worked perfectly with original setting. Seems to be something specific to my phone.

Thanks for the quick response. I've only been using Channels for a few days, but already it is light years better than the Plex DVR.

Original streaming uses a ton of bandwidth and won't work unless you have a huge network connection on both sides.