Channels App stuttering on Apple TV

Doing some more testing I enabled standard definition channel in the HDHomeRun.

The standard definition channel works without stuttering while the High Definition channel stutters on the non 4K Apple TV.

The 4K Apple TV still works without stuttering.

I can confirm this. I have 8 AppleTV’s. The two 4k’s I have are fine. The three HD’s that I have on 15.0 work fine. The three HD’s that updated to 15.1.1 all experience this stuttering. Wired or wireless and at the same location and using the same Ethernet cable as the ones that work fine. However, it is not only Channels (Live TV and recordings) that is doing this for me. Plex and Netflix are also doing it.

I wonder if this has been resolved in the latest beta release. I may try to test it later today.

It appears that the stuttering is resolved in TVOS 15.2 beta 2. I updated one Apple TV for testing and it is now playing smoothly.

If you need the beta profile it can be found TVOS 15.2 beta 2. And the instructions for installing here are the instructionsHere’s how to install tvOS 15 beta on your Apple TV.

1 Like

Thank you for the update. I have noticed the exact same issue with my Apple TV HD boxes, while my Apple TV 4K boxes are fine. Glad to hear tvOS 15.2 appears to solve the issue.

The 15.2 beta 2 worked for a while then started experiencing some issues. I am going to run some network test just to double check. The weird thing was when it started freezing the stops were more pronounced and it also occurred in the HDHomeRun app. But running the HDHomeRun app on multiple computers and Channels on the iPhone works perfectly.

I just updated one of my Apple TV HD's to tvOS Beta 15.2 and it does seem to be much improved. I'll have to keep an eye on it to see if it degrades again...

Upgraded my second Apple TV HD and it is also behaving much better.

Thanks for the tip!

Exactly the same happening here. My 4K ATVs are ok but the HD ATV is stuttering to the point where I can only watch SD channels. They said to try the latest beta but I can load it in TestFlight to try.

I just enabled Beta updates directly in my Apple TV HD's Settings -> System -> Update menu. Worked great.

I see that today a new TVOS 15.2 beta 3 was released. I will update one of the HD Apple TVs later today to see if there are any further improvements. Unfortunately the release notes for the new beta are not available at this time.

1 Like

I just did the same…I’ll check it out shortly. Thanks for the info.

So after updating to beta 3 today it helped with the stuttering. I also power cycled the router, the 5 Wi-Fi access points, the 2 HDHomeRuns and the Apple TV I update to test.

Things appear to working properly on the Apple TV I update. I will probably try the others tomorrow.

1 Like

Just read through this thread and I am having these exact issues on non-4K Apple TV’s with wired connection, no issues on 4K Apple TV. I will try the beta update for TvOS and see if it works.

It fixed the problem for me. Hopefully it will work for everyone else.

Afterwards I did some additional network improvements.

  • Added another Wi-Fi access point that I had sitting around.
  • Removed coax cable amplifier and powered splitter (installed by cable company) for powering every cable line in the house and plugged the cable to the room with the router and HDHomeRuns directly into the main line.
1 Like