DirecTV Auth Failure - Illegal Invocation

Hello! I'm brand new here and trying to get up and running. When I try to add DirecTV as a source, I input my credentials but I get the following error:

TypeError: Illegal invocation at reactValueSet (tveloginhelper.js:253:28) at formLogin (tveloginhelper.js:19:7) at attComLogin (tveloginhelper.js:123:5) at tveloginhelper.js:380:5

I've searched a whole bunch trying to get this solved, but I can't find any similar issues. Apologies if I'm being redundant, it's unintentional.

Just to be safe, I went ahead and uploaded my diagnostics: ca349992-8350-4658-8c57-5e9dd5dea3ee

Thanks in advance!

Same here from TruTV down to MSNBC. Using DirecTV as well.

Logs have been submitted as 75a6ddea-cf9e-46be-ab90-e5c851117990 .

I'm getting the same error using DirectTV

Same here...

Thanks for the diagnostics. New build coming with fix.


Literally one of the best devs ever


I assumed I was doing something wrong trying to get set up... I can't believe that you identified a bug from this and turned around a build so quickly. Responsiveness is quite the selling point!

1 Like

Place holder need to fix mine but recording right now on ota channels will wait

Still broken on QNAP version 2022.02.09.0020, will there be a QNAP update soon to fix?

There were several fixes for DirecTV authentication in the pre-releases since the last stable release. You can either wait for the next stable release, or you can update to a current pre-release.

I found it

same error for me

Channels says I'm using the latest version on my synology

Latest prerelease version?

stable version… should I do prerelease? If so, how?

Im pretty sure where it says check for update you can drop down the box and there should be a check for prerelease option.

thx! it'll need to update later because I'm recording right now. I'll try in a couple hours with direct and see what happens


Build 2022.03.19.0040 worked for me. Thx.