ESPN+ with Custom Channels

I'm getting a generic "Even will start soon" , even tho the event is playing live. Any ideas?

How long have you waited - Sometimes can take a minute or more to transition from the event will start screen to the stream.

It shows this as it prepares the stream.

Same issue with me. I really want this to work, but it’s getting frustrating.

I let it go a while. Logs eventually say unable to parse stream. No error on channels ui tho. Just that same screen.

I figured it out the issue. Once I turned off my Synology VPN , it started playing.

I'm getting the same issue when trying to figure out Docker in W10. If you find a fix , let me know. I'll do the same..

Someone mentioned earlier that there may be something related to 32 bit OS instead of 64 bit. Anyone think this could be why is working for some but not for others?

I'm running 64 bit and having all sorts of issues getting it to work. Docker on Win10.

64bit here too.

Does anybody know where this is located or does it need to be changed?

/config_dir:/app/config -v /dev/shm:/app/tmp

I found articles referring to correcting EACCESS with Sudo, but would that work in W10 environment?

In windows I use:

-v C:\docker_volumes\eplustv\config_dir:/app/config
-v C:\docker_volumes\eplustv\dev\shm:/app/tmp

Or I let the docker create annonymous volumes, so:

-v :/app/config -v :/app/tmp

That was it! That fixed it for me. God bless you.

If it is helpful, this is my revised docker run command. I am running this on a Synology 916+. Note that sudo is required for appropriate authority at least on the Synology box. Also, I removed the volume specification for the /app/tmp based on comments in the issues log. I was also getting the EACCES error in my logs. But this worked like a champ. I had forgotten to mention this in my earlier note.

Also, I discovered that unchecking the flags in the automated channels dialogue allowed it to pull for this source.

sudo docker run -p 8000:8000 -v /tmp:/app/config -e ACCESS_URI='http://[host_ip]:8000' -e ESPN_USER='[espn_id]' -e ESPN_PASS='[espn_password]' -e START_CHANNEL=7000 --name ESPN_Plus m0ngr31/eplustv

Give this man a prize! Totally got things working! Thanks!

1 Like

You are correct no need to map anything to /app/tmp inside the container. The container author suggests mapping /dev/shm to /app/tmp purely for performance reasons but its not necessary for it to run. Mapping it to another disk based dir serves no purpose. Which means you really only need to map something to /app/config inside the container for persistence purposes - so make sure whatever hostdir you map to it is a directory that will stick around on your host (in your example, not sure how permanent /tmp on a synology is)

New problem.

When attempting to tune-in to the stream I get this error:

Invalid URL - First path segment in URL cannot contain colon

This is what I am running. Can anybody tell me what I am doing wrong?

docker run -p 8000:8000 -v c:\docker_volumes\eplustv\config_dir:/app/config -v c:\docker_volumes\eplustv\dev\shm:/app/tmp -e ACCESS_URI='http://192.168.1.6:8000' -e ESPN_USER='[email protected]' -e ESPN_PASS='SecretPassword' m0ngr31/eplustv

Error Log:

2022/02/11 10:47:45.213926 [ERR] Could not start stream for M3U-EplusTV ch2 EPlusTV 2: M3U: Invalid URL: 'http://192.168.1.6:8000'/channels/2.m3u8: parse "'http://192.168.1.6:8000'/channels/2.m3u8": first path segment in URL cannot contain colon

I'm getting this also.

Try double quotes

That did the trick. Thanks.