Initial setup - cannot connect to server

Nothing appears but the same spinning wheel.

1 Like

If there's only a few lines in the log, you can post that here.
Try restarting the shield?

There are ton of lines as I have started and stoped the server a few times and rebooted the shield twice.

2023/09/14 21:53:01.000837 [SYS] Starting Channels DVR v2023.09.13.2351 (windows-x86_64 pid:15974) in C:\ProgramData\ChannelsDVR\data
2023/09/14 21:53:01.387730 [SYS] Started HTTP Server on 8089
2023/09/14 21:53:01.813004 [ERR] Failed to refresh auth: missing oauth client
2023/09/14 21:53:01.869561 [SYS] Bonjour service running for dvr-kpar-desktop.local.

Do you see lines like these showing it's running?
[SYS] Starting Channels DVR v2023.05.19.2045 (linux-x86_64 pid:7) in /channels-dvr/data
[SYS] Started HTTP Server on 8089
[DVR] Recording engine started in /shares/dvr

I never get the recording engine started message

As part of the initial setup, it should be asking you (in the browser) to login to to activate.

Sounds like maybe a bug in this new stable release version.

I never get to the login window. Right after I download the server it goes straight to the spinning wheel that never ends

Just to make sure, can you use a browser from another device on your local network and go to the IP address of your Windows PC

Thanks yeah I'll try that for sure. May not be until the AM though. Thanks a lot for the help hopefully it's a minor issue. I've used Channels for years with no issues so this is odd.

I was able to complete the setup in the using the IP address + /admin/settings link. It works now.

It's a bug with the new stable version.

I just tried a fresh install and am seeing the same thing.
@tmm1 @maddox @eric

2023/09/14 19:20:43.389701 [SYS] Starting Channels DVR v2023.09.13.2351 (linux-x86_64 pid:14176) in /var/packages/ChannelsDVR/target/channels-dvr/data
2023/09/14 19:20:45.969357 [SYS] Started HTTP Server on 8089
2023/09/14 19:20:46.459484 [HDR] Found 1 devices
2023/09/14 19:20:46.530091 [ERR] Failed to refresh auth: missing oauth client
2023/09/14 19:20:46.535134 [SYS] Bonjour service running for dvr-ds1513plus.local. []

Seeing this in the Console when trying to load the page

Uncaught (in promise) TypeError: t.user.username is undefined
    e90 app.jsx:31
    serverRequest globals.jsx:146
    e90 app.jsx:28
    _32 React
    unstable_runWithPriority scheduler.production.min.js:18
    React 3
    oO scheduler.production.min.js:16
    onmessage scheduler.production.min.js:12
    Z71 scheduler.production.min.js:12
    y bundle.js:1
    W71 index.js:4
    y bundle.js:1
    kn1 React
    y bundle.js:1
    y3 React
    y bundle.js:1
    <anonymous> app.jsx:4
    <anonymous> app.jsx:80
Source map error: Error: NetworkError when attempting to fetch resource.
Resource URL:
Source Map URL:
1 Like

I just subscribed to a trial month and am having a similar problem to what's being described here. I'm installing on a headless Windows machine, and I see the same spinning circle on that machine or connecting from a different machine on the same network.

The website required me to login to download the installer, but after I ran it the app did not appear to send me to the site to login (though I can't tell if any attempt at authentication happened in the background).

My log file (from
2023/09/14 22:40:57.883035 [SYS] Starting Channels DVR v2023.09.13.2351 (windows-x86_64 pid:12004) in C:\ProgramData\ChannelsDVR\data
2023/09/14 22:40:58.020540 [SYS] Started HTTP Server on 8089
2023/09/14 22:40:58.651912 [HDR] Found 1 devices
2023/09/14 22:40:58.746056 [ERR] Failed to refresh auth: missing oauth client
2023/09/14 22:40:58.892253 [SYS] Bonjour service running for dvr-netdvr.local. []

I'm using this with a HDHomeRun Flex 4K tuner, and have used both Edge and Firefox to try accessing the admin link.

Just installed Channels DVR app on Apple TV, purchased a one-year subscription to Channels DVR, and downloaded the Channels Server from the website today and installed it on my Mac. All I get is a spinning wheel. Here is the log:

2023/09/14 22:34:37.399937 [SYS] Starting Channels DVR v2023.09.13.2351 (darwin-arm64 pid:1536) in /Users/xxxxx/Library/Application Support/ChannelsDVR/data
2023/09/14 22:34:37.639777 [SYS] Started HTTP Server on 8089
2023/09/14 22:34:38.193803 [HDR] Found 1 devices
2023/09/14 22:34:38.243210 [ERR] Failed to refresh auth: missing oauth client
2023/09/14 22:34:39.000732 [SYS] Bonjour service registered with

The Channels DVR app on my Apple TV says it cannot find the Channels server that is supposed to be running on my Mac.

Any help to get this new system working would be appreciated. Trying to use Channels with a new HDHomeRun 4k Tuner. Thanks

Go here in your web browser
Using the IP address of your server in place of

@fjh3 @dvrftw @wcm3 @dkuchay

This ( successfully got me into a setup screen where I'm now making some forward progress. Thank you!

Thanks everyone for tracking this down. New release is coming out shortly.

Fixed and released as stable.

That did it thanks!

That worked @chDVRuser, along with the bug fix. Thanks folks, I like what I see.