M3u open/close no error, pointless log

So I open a channel it starts playing it freezes a screen blanks out sometimes black sometimes White and doesn't come back when I check the logs it shows that this channel was opened and the channel was closed.

how do I get more verbose logging to see what's going on?

Stream limit reached? Some issue on the service provider maybe?
I have had those issues with the various iptv services I have tried and put into Emby.

Note that Channels DVR does not support what they label as "illegal" iptv streams and may have coding or the design of how their software streams m3u links, may make it incompatible with certain services streams.

But far as my troubleshooting went with trying to figure out more details, it came down to all my server knows is that the connection was closed by the remote server.
You issue may be different.

Not sure what other log messages could be generated.

That's utter hooey. (I would have used more colorful language, but I'm trying to keep it more civil.) Before spreading some nonsense conspiracy theory, how about suggesting something within the realm of probability.

M3U playlists shared across the internet touting hundreds of free movies and channels often run into issues with concurrent streams, and usually have problems with regularly availability.

If I load a stream in VLC it's flawless when I load it through Channels this is what happens.

How about ffplay? It uses the same backend that Channels uses to receive streams.

its yours (or someones) hooey then...cause i have seen it said here, channels does not support such things and those streams will not work in them.

Edit. and its proven by they fact that i, and others here, have taken iptv .m3u's, and tried them in Channels, they dont work or have issues. Work fine in VLC, Emby, Plex, and various other players that support them. But not working right immediate at first load, is different that the inherent issues that random or shady iptv m3u streams have.

But, u fail to notice i said "may".

I never claimed they wouldn't work. I said they weren't supported, meaning the developers would not expend any effort to make them work better. Just because something isn't supported, does not mean it won't work.

(Windows 7 and Media Center are no longer supported, but they still work. Microsoft just won't help users with their issues on that software. Can you see the distinction?)

Addendum: Perhaps if the OP wants some actual help, giving the URL of the stream that won't work would help. Because short of offering details, everything is a guess.

So they are going to verify and validate every service that a user that come here and asks for help with....this person did not even state where or what iptv service or links they are using...why i was being general and just saying...if it is such shaddy or illegal, and it turns out it won't work in channels,,,then it won't work. goodbye

I'll try ffplay as a test. Thanks.

So it seems that it's Channels, I say that because here's what I'm doing...
I take my Verizon TVE channels m3u and save it... as a local file.

I copy/paste it as an M3U source and wipe out everything other than the stream and channel-id, name and title and give it my local verizon chno, then I can remap to my existing providers epg. So in the end it looks like this...

#EXTINF:-1 channel-id="6000" tvg-chno="504" tvg-logo="https://tmsimg.fancybits.co/assets/s28717_h3_ba.png?w=360&h=270" tvg-name="WNBCDT" group-title="HD",NBC

Now I get all my free channels mapped correctly, nothing illegal, works awesome and uses no additional services or hacks to get it working, just channels feeding channels...

It still drops the feed once I start a new one after like 30 seconds, then i have to exit the blank screen, go back in, and it either says playback failed, or it works, if it fails, i exit the channel and go back in, and then it works. So the streams from channels tve to channels m3u WORK, but they're inconsistently working on first load, but not always, sometimes first load works... it's odd.

You're using the wrong URL for your source. Replace hls/master.m3u8? with stream.mpg, and change the playlist type from HLS to MPEG-TS. Also, if you're setting up the new M3U playlist, it's probably better to use as your source's IP address, so if your server's IP address ever changes between reboots, the playlist will always be able to find the stream

Trying that now, i'll keep you posted, thanks.

So now they all look more or less like this:

#EXTINF:-1 channel-id="6000" tvg-chno="504" tvg-logo="https://tmsimg.fancybits.co/assets/s28717_h3_ba.png?w=360&h=270" tvg-name="WNBCDT" group-title="HD",NBC

Also, as I've posted elsewhere, if you're feeding your playlist from channels, you can strip out more from the #EXTINF line. All you need are:

  • channel-id – This is required by Channels
  • channel-number – Channels will prefer this tag for assigning channel numbers
  • tvc-guide-stationid – This allows Channels to map the guide data it already has onto your new stream

In your case, your minimal example would be:

#EXTINF:-1 channel-id="wnbcdt" channel-number="504" tvc-guide-stationid="28717",NBC

Does a lookup exist that will give me the stationid? I wasn't aware of one where I can like, choose Verizon in my area and see channel names or logos, other than the default provider lookup which is what I had to use. Well, not really, I did the tvg-chno and that matched up with the local epg... so...

When you export the M3U from Channels, it includes that tag on streams it has data for. Also, in the tvg-logo tag, the stationID is in the filename of the channel logo, prefixed by s.

You may find this thread something worth reading, since this has all already been discussed and documented:

Yeah I got the EPG no problem by making sure the chno was what the local guide would map to. The stream freezing was the issue, now with your insight about not using HLS and using the more direct mpg this should hopefully correct that 1 issue.

Thank you!

Nope, still happens. Some channels are fine, others freeze after a bit, some won't even load at first attempt, etc... When you go out and back, they work.

What client platform/device/version?

Clients are all Android, 4 of them are mibox s, 1 is a sony smart tv, and 1 is S21 ultra. 3.11 is the version on the one I just tested which was a mibox s.

I've just submitted diagnostics from the crashing/freezing one.