Mac Server System Service Problem

I'm having trouble getting the DVR service to install as a system service on my Mac mini. I ran the script that is on the download page, but get this error:

ERROR: Channels DVR is already installed as a user-service.
ERROR: Uninstall it before installing as system-wide service.

I've installed and reinstalled and snooped around but can't seem to figure out what I'm doing wrong.

As I move things around and attempt the script again I sometimes get the alternative message:

/Library/LaunchDaemons/com.getchannels.dvr.plist: service already loaded
Load failed: 37: Operation already in progress

This still does not make it so that the server opens on restart without logging in, which is the goal.

Is this too confusing or am I making an obvious mistake that's causing this?

Please provide the full command you ran and all the output. It's not clear from the information you provided.

[email protected] ~ % ~/Library/Application\ Support/ChannelsDVR/install.sh --system

ERROR: Channels DVR is already installed as a user-service.

ERROR: Uninstall it before installing as system-wide service.Screen Shot 2020-11-18 at 1.37.52 PM

*This is run after doing a clean install

Thanks. If you run the installer again, does it show a Stop option? If you select that first, then the command in Terminal should succeed.

Attempted that... Just tried again and the "stop DVR" button seems to have no functionality over my currently running user-service Server.
I check the "log" after clicking "stop DVR" and nothing has changed, it is still running. Tried the command anyway and it produces the same response.

Okay try running this, paste it two times and then copy/paste all the output shown:

~/Library/Application\ Support/ChannelsDVR/uninstall.sh
~/Library/Application\ Support/ChannelsDVR/uninstall.sh

I am on my laptop as well trying to make sure it's not a computer issue... this is the other full terminal response:

Screen Shot 2020-11-18 at 1.48.22 PM

Text:
[email protected] ~ % ~/Library/Application\ Support/ChannelsDVR/uninstall.sh

~/Library/Application\ Support/ChannelsDVR/uninstall.sh

NOTE: Your password is required to uninstall Channels DVR.

NOTE: Please enter it at the prompt below.

Password:

Channels DVR has been uninstalled as system-wide service.

Channels DVR has been uninstalled as user service.

[email protected] ~ % ~/Library/Application\ Support/ChannelsDVR/uninstall.sh

~/Library/Application\ Support/ChannelsDVR/uninstall.sh

ERROR: Channels DVR is not installed.

ERROR: Channels DVR is not installed.

[email protected] ~ %

That looks more promising. Now try the original install system command and hopefully it works. If you're still getting weird load failed errors, you may need to reboot.

Rebooted and it did not start up... tried command again and this is result:Screen Shot 2020-11-18 at 1.52.38 PM

What does this show:

sudo launchctl list | grep dvr
launchctl list | grep dvr

Just submitted:

e8d511a6-7f31-4dc4-a2d1-a33913d322bb

I will run that command and let you know.

This is a screenshot of my console log, The top is after restart, before login... It seems to try something but run in circles?

Screen Shot 2020-11-18 at 2.02.40 PM

launchctl list com.getchannels.dvr

sudo launchctl list com.getchannels.dvr

[email protected] ~ % launchctl list com.getchannels.dvr

sudo launchctl list com.getchannels.dvr

Could not find service "com.getchannels.dvr" in domain for port

{

"StandardOutPath" = "/Users/amb21495/Library/Application Support/ChannelsDVR/data/channels-dvr.log";

"LimitLoadToSessionType" = "System";

"StandardErrorPath" = "/Users/amb21495/Library/Application Support/ChannelsDVR/data/channels-dvr.log";

"Label" = "com.getchannels.dvr";

"OnDemand" = false;

"LastExitStatus" = 0;

"PID" = 653;

"Program" = "/Users/amb21495/Library/Application Support/ChannelsDVR/latest/channels-dvr";

"ProgramArguments" = (

"/Users/amb21495/Library/Application Support/ChannelsDVR/latest/channels-dvr";

);

"PerJobMachServices" = {

"com.apple.tsm.portname" = mach-port-object;

"com.apple.axserver" = mach-port-object;

"com.apple.coredrag" = mach-port-object;

};

};

[email protected] ~ %

It appears like its already running as a system service.

Do you know why it won't boot at startup then? It appears to be attempting and failing until I log the user in. This seems to repeat itself and attempt a boot but never finish?

It is not clear from those logs. It could be getting shut down by something else, or it could be crashing. But if it was crashing I would expect a crash message and there is none. You may need to open Console.log and look to see if there are kernel crashes.

What version of macOS are you running?

That most recent shot is the Console log. I submitted another diagnostic after a reboot... hoping it’ll show you what’s happening to make it fail? It’s trying... then tries again... and again.......

I’m on the most recent Big Sur 11.0.1

Does this show anything:

sudo dmesg | grep -i dvr