MLB Network Not Working on TV Everywhere

Every time I try watching MLB Network using the Channels app on my Nvidia Shield it doesn't work. I am able to login and watch on the MLB Network website using my Spectrum credentials. Is anyone else having this problem? Here's the error from my log:

2020/01/11 19:29:22 [ERR] Could not start stream for TVE-Spectrum ch6193 MLBTV: TVE: Could not fetch playlist: http://mlblive-akc.mlb.com/ls01/mlbam/mlb_network/NETWORK_LINEAR_1/master_wired.m3u8: Get http://mlblive-akc.mlb.com/ls01/mlbam/mlb_network/NETWORK_LINEAR_1/master_wired.m3u8: EOF

Update your dvr by click and hold the Update button

That worked! Thanks.

I have updated and I'm still not able to get the channel going. I also recreated the database and guide as I moved setup back to my WD PR2100 NAS and MLB Network still isn't working.

Did you click-and-hold the Update button?

No I didn't. Completely forgot. Oops. It's working now. Thanks for the help

For future reference, I was just (a year+ later) experiencing the same issue and saw this in the log:

2021/04/01 08:33:33.474483 [ERR] Failed to start stream for ch6193: TVE: Stream Not Available
2021/04/01 08:33:33.491483 [HTTP] | 200 | 1.1334088s | 10.255.1.3 | GET "/devices/ANY/channels/6193/hls/master.m3u8?abr=false"
2021/04/01 08:33:33.545483 [HLS] Couldn't generate stream playlist for ch6193-dANY-ip10.255.1.3: TVE: Stream Not Available
2021/04/01 08:33:33.545483 [HLS] Stopping transcoder session ch6193-dANY-ip10.255.1.3

I went to check on the cable provider's (Cox) TVE platform and saw this:

As such, even though it came through as a valid TVE channel, because I'm not on the same internet at this location it is not valid.

@tmm1, any chance the TVE channel scan can recognize if a channel is not valid because the server is not on the home network?

@tmm1 Its missing as an available channel for me as well. Dont even see it to add in my source (optimum). Bad timing. Today is opening day.

MLB changed their website and no longer let you watch with just a cable login. You have to create an MLB account first. This is not something our TVE integration can handle, so the channel is no longer supported.

Hope this isn't a sign of things to come. The YES network is showing a still image and not the Yankee game today.

That's because starting today FoxSportsGo will no longer carry the Yes Network. The new location to watch is https://watchyesnetwork.com/watch

But I doubt it will be implemented into Channels as it also requires you to first sign in with an email before letting you enter your tv provider credentials.

1 Like

Exactly. I noticed that when I dowloaded the YES app. Thats why I said I hope this is not a sign of things to come. YES was not part of the sale to Sinclair / Bally Sports rebranding. :expressionless:

I’m trying to find the m3u that MLB uses if you watch MLB Network in a web browser.

( https://www.mlb.com/network/live )

The link let’s me watch MLB Network after I’ve logged in with my MLB account and then authenticate with my DirectTV login. I’ve only been asked to link my DirecTV credentials the one time. I’m hoping I can just create a custom m3u channel for it? Who knows?
Does anyone have any idea how I can find the m3u?
Thank you!

Don't know if you visit this site much, but there's a solution a user came up with in the topic below

he's talking about MLB network, not MLB TV.

1 Like

Use Firefox and add the addon, "The Stream Detector". It will find the m3u8 stream. I just tried this and was able to play the stream in VLC. I did not create a custom channel with the stream however.

3 Likes

That method will only work for a short time as the url has a token in it that will expire within a number of hours.

1 Like