NEW: Channels DVR backend for Nvidia SHIELD


#101

Sound advice, which I’ll be following in the future…Thanks :grinning:


#102

Overnight Failure:

2017/05/31 22:39:27 [SYS] Starting Channels DVR v2017.05.25.2249 (android-arm64) in /data/data/com.getchannels.dvr/files/channels-dvr/data
2017/05/31 22:39:28 [HDR] Found 1 devices
2017/05/31 22:39:29 [SYS] Started HTTP Server
2017/05/31 22:39:33 [DVR] Recording engine started in /storage/E848DA7348DA404C/NVIDIA_SHIELD/Channels
2017/05/31 22:39:33 [DVR] Waiting 3h35m26.703269383s until next job 1496297700-ch456 The Town (2010)
2017/05/31 22:39:33 [SYS] Created database snapshot: backup-20170531.223933
2017/05/31 22:39:43 [IDX] Pruned 19 expired airings from USA-FL61795-X in 210.448125ms.
2017/06/01 02:15:00 [DVR] Starting job 1496297700-ch456 The Town (2010) on ch=[456]
2017/06/01 02:15:00 [DVR] Waiting 5h44m59.952656762s until next job 1496318400-ch658 Narrow Margin (1990)
2017/06/01 02:15:00 [TNR] Opened connection to 1318CAEB for ch456
2017/06/01 02:15:16 [WRN] Buffer for 1318CAEB ch456 is more than 50% full (clients=1, len=16777684)
2017/06/01 02:15:18 [DVR] Recording for job 1496297700-ch456 from 1318CAEB ch456 into “Movies/The Town (2010) 2017-06-01-0215.mpg” for 2h59m59.940053741s
2017/06/01 02:15:19 [ERR] Could not lookup program MV002783580000: invalid response for /programs/MV002783580000?imageAspectTV=2x3&api_key=: 503 Service Unavailable
2017/06/01 02:25:38 [TNR] Closed connection to 1318CAEB for ch456
2017/06/01 02:25:38 [DVR] Error running job 1496297700-ch456 The Town (2010): write /storage/E848DA7348DA404C/NVIDIA_SHIELD/Channels/Movies/The Town (2010) 2017-06-01-0215.mpg: transport endpoint is not connected


#103

Apparently the Shield likes randomly disconnecting your USB (and NAS mount points). It’s aggravating.


#104

I’ll give it another week, but at this point, I’m ready to return to Qnap. Way too many disconnects. So sad :sob:


#105

5.2 should be out by then as well, and I know with it comes writing to a NAS and fixes for disconnects from a NAS, but not sure about USB.


#106

@timstephens24, thanks for the heads up. Hopefully not just for Plex DVR:

" To allow for all of this on SHIELD TV, the update essentially brings two new features: Ability to write to network storage (allowing customers to record TV shows and movies directly to their network attached storage (NAS) via Plex) … "

This is good news, I’d much rather write to NAS than USB 3. And hopefully it will eliminate the USB disconnects or make same moot.

P.S. On my latest…Shield did not totally disconnect from the USB 3, it was just reading the drive at 0kb. Was able to eject and re-add without a reboot of drive.

Wonky!


#107

Apparently it’s only going to allow specific apps on a white list to write to a mounted drive (I’m guessing to keep malware from encrypting all your files) so it might not actually be in this update for Channels.

Also have a weird issue… I tried going to the web interface, and it wasn’t working. I switched over to my Shield input and restarted the server. Here’s all the log shows:

2017/06/01 21:48:23 [SYS] Starting Channels DVR v2017.05.25.2249 (android-arm64) in /data/data/com.getchannels.dvr/files/channels-dvr/data
2017/06/01 21:48:24 [HDR] Found 3 devices
2017/06/01 21:48:25 [SYS] Started HTTP Server
2017/06/01 21:50:33 [SYS] Starting Channels DVR v2017.05.25.2249 (android-arm64) in /data/data/com.getchannels.dvr/files/channels-dvr/data
2017/06/01 21:50:34 [HDR] Found 3 devices
2017/06/01 21:50:35 [SYS] Started HTTP Server
2017/06/01 21:52:53 [SYS] Starting Channels DVR v2017.05.25.2249 (android-arm64) in /data/data/com.getchannels.dvr/files/channels-dvr/data
2017/06/01 21:52:54 [HDR] Found 3 devices
2017/06/01 21:52:55 [SYS] Started HTTP Server
2017/06/01 21:54:49 [SYS] Starting Channels DVR v2017.05.25.2249 (android-arm64) in /data/data/com.getchannels.dvr/files/channels-dvr/data
2017/06/01 21:54:50 [HDR] Found 3 devices
2017/06/01 21:54:51 [SYS] Started HTTP Server
2017/06/01 21:56:29 [SYS] Starting Channels DVR v2017.05.25.2249 (android-arm64) in /data/data/com.getchannels.dvr/files/channels-dvr/data
2017/06/01 21:56:30 [HDR] Found 3 devices
2017/06/01 21:56:30 [SYS] Started HTTP Server
2017/06/01 21:58:29 [SYS] Starting Channels DVR v2017.05.25.2249 (android-arm64) in /data/data/com.getchannels.dvr/files/channels-dvr/data
2017/06/01 21:58:30 [HDR] Found 3 devices
2017/06/01 21:58:31 [SYS] Started HTTP Server
2017/06/01 22:00:39 [SYS] Starting Channels DVR v2017.05.25.2249 (android-arm64) in /data/data/com.getchannels.dvr/files/channels-dvr/data
2017/06/01 22:00:40 [HDR] Found 3 devices
2017/06/01 22:00:40 [SYS] Started HTTP Server
2017/06/01 22:02:49 [SYS] Starting Channels DVR v2017.05.25.2249 (android-arm64) in /data/data/com.getchannels.dvr/files/channels-dvr/data
2017/06/01 22:02:50 [HDR] Found 3 devices
2017/06/01 22:02:51 [SYS] Started HTTP Server
2017/06/01 22:04:47 [SYS] Starting Channels DVR v2017.05.25.2249 (android-arm64) in /data/data/com.getchannels.dvr/files/channels-dvr/data
2017/06/01 22:04:49 [HDR] Found 3 devices
2017/06/01 22:04:49 [SYS] Started HTTP Server
2017/06/01 22:06:06 [SYS] Starting Channels DVR v2017.05.25.2249 (android-arm64) in /data/data/com.getchannels.dvr/files/channels-dvr/data
2017/06/01 22:06:07 [HDR] Found 3 devices
2017/06/01 22:06:08 [SYS] Started HTTP Server


#108

@DebbieFL I haven’t had any problems with Shield file sharing drops for a while now. However, before the last couple of updates it dropped all the time. It used to happen more often than not when I tried to mount from two different machines, and when I stopped doing that it became rare. But, as I said, of late it’s been rock solid.

Note that you can add an ssh server without rooting it, and then it’s possible to use rsync for any file copying and backup; I found that to be more reliable than SMB.


#109

I asked around at NVIDIA and SiliconDust about the USB disconnect problem and there doesn’t seem to be any known issues about it. If you’re using a USB2 hub it could cause problems, but should be fine otherwise…

It might be worth pulling the logs from the Android OS to see if there’s anything useful in there about the disconnects. I’m not sure offhand what the best way to do that is…


#110

For comskip failures, can you run this command on a couple of the recordings (replace IP and 123 with recording ID from log):

curl -s http://x.x.x.8089/dvr/files/123/comskip.log | tail -2


#111

LOGOS

IMac-4:~ Debbie$ Curl -s http://10.0.0.33:8089/dvr/files/186/comskip.log | tail -1
No such file or directory - could not create file /storage/E848DA7348DA404C/NVIDIA_SHels/Logs/comskip/186/video.logo.txt

Checked 3 diff files from 3 diff 720 channels = same

Reading the log file itself:

Looking for Logo …
not enough edge count - 0

Checking a successful files Logo found

Noticed you changed to tail -2…while I was writing.

Do you want one of the failed log files?


#112

-2
IMac-4:~ Debbie$ Curl -s http://10.0.0.33:8089/dvr/files/186/comskip.log | tail -2
Logo found at frame 6372 logoMinX=426 logoMaxX=518 logoMinY=291 logoMaxY=332
No such file or directory - could not create file /storage/E848DA7348DA404C/NVIDIA_SHels/Logs/comskip/186/video.logo.txt


#113

BTW

Also checked on source for @timstephens24 comskip failures on Shield DVR listed earlier … all were on 720p broadcast stations.

Additionally, I simultaneously recorded the same 720 broadcast on 3 different Channels DVR. Only 1 failed comskip…the Shield install.


#114

On the Shield:

Today, was the first day that I was able to obtain a recording (with successful comskip) without any negative interference.

DVR restarted 3x (2x last night and 1x ~4 hours before recording this pm).

No drops of storage occurred.


#115

Well after just over one week of no issues with remote access the Shield suddenly is not allowing remote access again. I have tried to setup my router with and without manual port forwarding but no change. Tried rebooting the router and the Shield, no change. It gives me the following error in the log when I uncheck and then re-check the remote access box in the DVR settings page:

2017/06/03 08:10:00 [NAT] Failed to discover gateway: no gateway found
2017/06/03 08:10:00 soapRequest returned error: Post http://192.168.1.1:53695/ctl/IPConn: dial tcp 192.168.1.1:53695: getsockopt: connection refused
2017/06/03 08:10:00 [NAT] Failed to map port using upnp: Post http://192.168.1.1:53695/ctl/IPConn: dial tcp 192.168.1.1:53695: getsockopt: connection refused

My guess is this is likely related to router settings but I never had this issue when I ran the DVR on my Mac, on my QNAP NAS, or on a HP Chromebox…would like to use the Shield but no remote access is beginning to frustrate me.


#116

If you setup a manual port forwarding rule on your router, then just leave the Remote Access checkbox unchecked.


#117

I had tried that the first time I set this up on the Shield when the remote connection was not working, didn’t work previously but today that did the trick. Don’t know if it’s the router, the Shield, or just me being stupid but either way glad it’s working.

Thanks for the help and keep up the great work, absolutely love Channels and the DVR!


#118

Shield overnight, checking this am:

USB3 again - reading at 0kb - did a restart on Shield, now reading properly

Should I reformat this NTFS 8TB to exfat? Read in forums that some did so to solve the perceived NTFS problem on Shield.

2017/06/03 19:00:00 [DVR] Starting job 1496530800-ch522 The Jackal (1997) on ch=[522]
2017/06/03 19:00:00 [DVR] Waiting 3h59m59.958299923s until next job 1496545200-ch420 The Proposal (2009)
2017/06/03 19:00:00 [TNR] Opened connection to 1318CAEB for ch522
2017/06/03 19:00:00 [DVR] Recording for job 1496530800-ch522 from 1318CAEB ch522 into “Movies/The Jackal (1997) 2017-06-03-1900.mpg” for 2h59m59.958244975s
2017/06/03 19:42:20 [TNR] Closed connection to 1318CAEB for ch522
2017/06/03 19:42:20 [DVR] Error running job 1496530800-ch522 The Jackal (1997): write /storage/E848DA7348DA404C/NVIDIA_SHIELD/Channels/Movies/The Jackal (1997) 2017-06-03-1900.mpg: transport endpoint is not connected
2017/06/03 19:42:21 [DVR] Starting job 1496530800-ch522 The Jackal (1997) on ch=[522]

The actual file only had beginning 2 min of recording, although the above listed error was at 42m


#119

Mine’s exfat and it was doing the same thing, so I don’t think it’s going to matter. I’m in the preview update program, so I’m testing it on my external with 5.2 to see if it’s something they’ve fixed.

Side question: anyone else running Plex and Channels on the same box? It seems like running with both of them on keeps restarting Channels so I haven’t been getting new guide updates or able to record much of anything. I turned the Plex Server off and Channels has now been running for 4 hours and successfully recorded shows (it wasn’t previously). Might need to use one Shield for Channels (if USB drives are fixed I’ll do Channels on the normal Shield) and one for Plex.


#120

I joined the preview program a couple of days ago…but no 5.2 for me yet. :cry:

Due to other Plex Server problems on the Shield after adding Channels, I have to agree with your analysis. Will be very interested of your results with only Channels running on Shield.

Poor me, only 1 Shield… and I need the Plex Server to combine multiple Channels file locations.

Sooooo, back to Qnap for Channels.

BTW: Added MrMc to Shield. Super fast file load times. Great ffd, etc. Love it.