NEW: Roku app for Channels DVR (experimental)


#21

Thanks. What do you see on screen? An error message saying the DVR isn’t found? Or just the spinner looking for the DVR.


#22

I’m attaching a photo.

When I press the back button, it kicks me out of the app and back to the Roku home screen.


#23

Thanks. On your DVR web UI, under the bonjour checkbox, does it list one IP or multiple?


#24

Two


#25

I should clarify; I do have two NICs in my QNAP, and utilize them both. The second NIC is what all y Docker containers are bridged to. Everything else I do is through the first NIC.


#26

Are the TV and the DVR connected to the same router/switch, or are there multiple hops between them?


#27

Sorry, I meant to reply sooner. What I ended up doing is disconnecting the second NIC and utilizing it as a backup instead of a bridge for my docker containers, the. Restarted the Channels DVR service, which then yielded a single IP on the Channels dashboard. I was ten able to run the Roku app successfully, with it picking up my channels.


#28

Oh cool, good to know! I suspected the second IP was the issue, but wasn’t sure.

I guess it would be nice if the Roku app let you enter an IP manually as well. I’ll add that to the list for whenever I get back to improving this app.


#29

Yeah, I think that adding in a manual IP option would be good. I’m going to try and stick to my single (teamed) NIC setup for now, but I can see it being a good thing if someone else might find themselves in the same situation I was in.


#30

A quick update. The Channels app on Roku has been working fine for me since I eliminated the second IP on my QNAP, but this morning it is no longer working. It is again saying that it wasn’t able to find the DVR on my network. I restarted the Channels DVR service and that didn’t do it. I then rebooted my QNAP, and that didn’t do it, then I rebooted my router and that didn’t do it. Meanwhile my two Apple TVs have no trouble seeing the DVR and work fine. So it seems that perhaps there something more going on than just the two IP thing.


#31

If you leave the app and relaunch it a few times does it help?

Unfortunately Roku doesn’t support the Bonjour protocol, so we are using a different method for discovery which could be less reliable on certain networks.


#32

I restarted the app 10 times in a row with no luck. Sounds like a manual IP option is the way to go.


#33

The Roku app has been updated. I tweaked the bootup sequence that looks for the DVR, so hopefully it’s a bit more reliable now.

Also added an Up Next and Movies section, so you can watch your DVR recordings. Just like all the other clients, the player will keep track of how much you’ve watched and resume wherever you left off.



#34

Just updated the app on my Roku TV, and it still does not detect the Channels DVR running on my QNAP. I tried launching it like 6 times in a row and it never finds it.


#35

Bummer. I’ll take a stab at the IP entry dialog tomorrow.


#36

Thanks.

I’m very curious if it’s something specifically related to hosting the Channels DVR on a QNAP device. Any reports of success with the Roku app with QNAP? Anyone?


#37

Unlikely. If anything it’s related to the network stack on the Roku TV, not receiving udp multicast packets reliably.


#38

Pushed out another build just now. Still no IP entry, but it tries to send out the discovery UDP packets in a few different ways now. Also will now remember the IP once it’s found, so that should help in cases where it only sometimes works.


#39

Cool. So I updated the app and it immediately finds the DVR when it opens up, woohoo!

Now that the app finds the DVR, I’ve discovered it’s pretty unusable on my TCL Roku TV. For both live shows and recordings, it most of the time will show the black screen with the purple “retrieving” bar, the bar will fill up, and then nothing will play. It just stays at the screen with the retrieving bar. A couple times I left it for over 5 minutes and it never went anywhere.

For the times when it actually brings me to the channel or recording I picked, the video is in slow motion, while the audio sounds just fine. I tried this for both live/recorded programs in 1080i and 720p, and it happens on them both.

For reference, I am able to stream videos of varying formats and bitrates through Plex app the same Roku TV with no issues.


#40

Cool, glad the discovery issue is sorted.

I think I know why it’s not playing back correctly. The Roku TV can only support h264 4.1, but we are using 4.2

I’ll push some fixes next week.