QVC's on TVE - 40x Errors

It's been reported to me by a zealous QVC consumer that the TVE QVC's are erroring out with 400s.

Troubleshooting looks okay, but the URL looks a bit suspicious to me. I can rescan them w/o any issues.

2022/06/03 11:50:00.945344 [ERR] Failed to start stream for ch6953: TVE: Could not fetch playlist: lsqvc1us-lh.akamaihd.net: get https://lsqvc1us-lh.akamaihd.net/i/[email protected]/master.m3u8: 400 Bad Request
2022/06/03 11:50:00.956788 [HLS] Couldn't generate stream playlist for ch6953-dANY-ip192.168.88.2: TVE: Could not fetch playlist: lsqvc1us-lh.akamaihd.net: get https://lsqvc1us-lh.akamaihd.net/i/[email protected]/master.m3u8: 400 Bad Request
2022/06/03 11:50:00.956838 [HLS] Stopping transcoder session ch6953-dANY-ip192.168.88.2
2022/06/03 11:50:01.977992 [ERR] Failed to clean up /share/Streaming/ch6953-dANY-ip192.168.88.2-3943315910: unlinkat /share/Streaming/ch6953-dANY-ip192.168.88.2-3943315910/cache: directory not empty
2022/06/03 11:59:09.367364 [TRS] DNS: OK: Resolved host via system DNS
2022/06/03 11:59:09.686450 [TRS] Cloud Reachable: OK: Connected to community.getchannels.com
2022/06/03 11:59:09.988121 [TRS] Local Time: OK: Local clock is accurate
2022/06/03 11:59:09.994690 [TRS] TV Everywhere: OK
2022/06/03 11:59:10.226540 [TRS] TV Everywhere DNS: OK: Resolved TVE authenticator via system DNS
2022/06/03 11:59:10.616327 [TRS] Remote Access: OK: Successfully established external connection
2022/06/03 11:59:10.618639 [TRS] Disk Permissions: OK

A get via curl to that URL:

$ curl -v https://lsqvc1us-lh.akamaihd.net/i/[email protected]/master.m3u8
*   Trying 23.216.55.152:443...
* Connected to lsqvc1us-lh.akamaihd.net (23.216.55.152) port 443 (#0)
* ALPN, offering h2
* ALPN, offering http/1.1
* successfully set certificate verify locations:
*  CAfile: /etc/ssl/certs/ca-certificates.crt
*  CApath: /etc/ssl/certs
* TLSv1.3 (OUT), TLS handshake, Client hello (1):
* TLSv1.3 (IN), TLS handshake, Server hello (2):
* TLSv1.2 (IN), TLS handshake, Certificate (11):
* TLSv1.2 (IN), TLS handshake, Server key exchange (12):
* TLSv1.2 (IN), TLS handshake, Server finished (14):
* TLSv1.2 (OUT), TLS handshake, Client key exchange (16):
* TLSv1.2 (OUT), TLS change cipher, Change cipher spec (1):
* TLSv1.2 (OUT), TLS handshake, Finished (20):
* TLSv1.2 (IN), TLS handshake, Finished (20):
* SSL connection using TLSv1.2 / ECDHE-ECDSA-AES128-GCM-SHA256
* ALPN, server accepted to use http/1.1
* Server certificate:
*  subject: C=US; ST=Massachusetts; L=Cambridge; O=Akamai Technologies, Inc.; CN=a248.e.akamai.net
*  start date: Jul 15 00:00:00 2021 GMT
*  expire date: Jul 20 23:59:59 2022 GMT
*  subjectAltName: host "lsqvc1us-lh.akamaihd.net" matched cert's "*.akamaihd.net"
*  issuer: C=US; O=DigiCert Inc; CN=DigiCert SHA2 Secure Server CA
*  SSL certificate verify ok.
> GET /i/[email protected]/master.m3u8 HTTP/1.1
> Host: lsqvc1us-lh.akamaihd.net
> User-Agent: curl/7.74.0
> Accept: */*
>
* Mark bundle as not supporting multiuse
< HTTP/1.1 400 Bad Request
< Server: AkamaiGHost
< Mime-Version: 1.0
< Content-Type: text/html
< Content-Length: 175
< Expires: Fri, 03 Jun 2022 19:02:24 GMT
< Cache-Control: max-age=0, no-cache, no-store
< Pragma: no-cache
< Date: Fri, 03 Jun 2022 19:02:24 GMT
< Connection: keep-alive
< Access-Control-Allow-Headers: *
< Access-Control-Expose-Headers: *
< Access-Control-Allow-Methods: GET, HEAD, OPTIONS
< Access-Control-Allow-Origin: *
< Set-Cookie: _alid_=W29NrdD1Awl/TX5kHP8oDA==; path=/i/[email protected]/; domain=lsqvc1us-lh.akamaihd.net
<
<HTML><HEAD><TITLE>Error</TITLE></HEAD><BODY>
An error occurred while processing your request.<p>
Reference&#32;&#35;181&#46;98792b17&#46;1654282944&#46;85236c
</BODY></HTML>
* Connection #0 to host lsqvc1us-lh.akamaihd.net left intact

Does it work on https://www.qvc.com/content/shop-live-tv.html?qq=mh

Yeah, that works okay. The URL for that shows as:

https://qvc-amd-live.akamaized.net/hls/live/2034113/lsqvc1uscln/master.m3u8

Same here.
The QVC channels say "Playback Failed".

Same issue Spectrum TVE QVC 1, QVC 2, and QVC 3.

1 Like