Smart Collections and Error Logs dont work

Edit: I emailed logs to [email protected]. I just copied and pasted.

1st logs is running on laptop after fresh install. Starts off as regular ISP then I switched to PDA Net
2nd logs is running on Nas after a fresh install. Regular ISP.

Server: Asustor NAS
Clients: Galaxy S10, Shield Pro, Shield Tube, Galaxy S9

Since the update that introduced Automatic Smart Collections on Android I have not been able to use Automatic Smart Collections. They dont work for me. Anytime I attempt to submit a diagnostic log I get a error. Manually added channels do however show up.

2022/03/23 08:08:53.966699 [ERR] Diagnostics submission failed: Put "": context deadline exceeded (Client.Timeout exceeded while awaiting headers)

Steps I have taken to fix issue (not in order)

Reset my modem/router back to factory default
Switch my DNS server from ISP provided to OpenDNS
Uninstalled and reinstalled channels App
Change my ISP (I hotspotted my phone to my server to verify it was not a issue with ISP)
I am able to succesfully ping ""
Disabled firewall on my router
Disable Firewall on Channels server
Rebooted Server
Updated to latest beta (2022.03.23.0209)
Tried running channels through Nord VPN to see if it made any difference (Channels is not usualy behind VPN, i was just trying stuff)

No matter what Smart channels collections refuse to work and only provide errors. I am not as concerned about not being able to submit logs. I am more concerned about channels collections. This is a feature I have been looking foreward to FOREVER! The ability for smart collections makes all these darn M3U sources finaly worth something.

I can copy and paste logs and email them to you if you like.

Any trouble shooting advice is welcome.

More stuff I just tried.
I installed Channels onto my old Win10 Laptop. Still get same error when submitting diagnostics. Still unable to load Smart Collections.

I then disconected from wifi and using PDA Net (USB tether) as my isp I am still unable to submit logs. This is now on 2 different machines I am experiencing this. With 2 different ISP. I tried PDA Net with and without using Nord VPN to see if it made any difference. I know PDA Net is not best ISP source. But its only 2nd ISP i had to test.

2022/03/23 08:40:09.316849 [ERR] Diagnostics submission failed.
Put "": context deadline exceeded (Client.Timeout exceeded while awaiting headers)

While using PDA net I am unable to verify if smart collections works. As i cant connect client (no wifi).

Am I doing something wrong in Smart collections? I tried selecting EVERY catagories, leaving catagories blank. I tried selecting TV, Movies and Everything. I have tried enabling disabling the New, HD, Live.

Please tell me someone else is experiencing any of these issues and I am not loosing my mind. This is frustrating

edit: If I go to the url in the error message I get this

The request signature we calculated does not match the signature you provided. Check your key and signing method.

How do I fix signature. Do i need to use a differnent pen? Maybe I should switch to blue ink. Where do I sign. LOL

How many recordings are on your dvr?

What version number is shown inside the Channels app on your android device?

Please screenshot your settings for your channel collection.

Does it work if you change the name of your collection?

Did you send the collection to the client via server settings?

Good news and bad news. Good news is im an idiot. Bad news is I wasted 3.5hrs this morning trying to figure it out.

Channels collections is now working (Good).
I am still unable to submit logs (Bad).
I kept assuming the channels collections issue was related to the inability to submit logs. They are 100% separate problems.

As far as the channels collections. I am a moron. A absolute bafoon who missed something so obvious. I update my server 3-5x a week. Especially when something breaks. Ummmmm. . . I dont remember the last time I updated the client. I mean like really. On any device I dont think I have EVER updated the client after installing it. If it works you kind of forget about it.
@Everyone update your clients occasionally.

As far as the server goes. I am still unable to submit logs. This is only a minor annoyance.

9,463 recordings

Updating to ver 203.22.2330 fixed the channels collections issue.

@tmm1 So now only problem left is why cant I submit logs? Did you recieve my logs when I emailed them to you? Are the logs we see in log the same thing that is sent to you when we submit logs? If its the same thing I will probably ignore the problem as I can always copy/paste email. But if you have any ideas on howto resolve log submission issue shoot them my way.

I still cant believe i have NEVER updated any channels clients in probably over a year

Try this one:

1 Like

Just updated to the beta. I got a new error I have never recieved.

Local Time
Could not connect to Get "": context canceled

That error went away the next time I loaded troubleshooting screen. WOOT!

However for the first time in many days I got logs submitted.

Logs have been submitted as cb84c531-a407-4f5a-bd96-391cf7b22c62 . Please send an email to [email protected] to give details about the issue you're having

So I give that a overall Win. And to think i was angry @tmm1 this morning for picking on me and excluding only me from the cool new android freatures today.