SSL issue on Remote DVR

I’m getting the following error on iOS 11.2.6 (iPhone and iPad) when trying to access Remote DVR: “DVR Access Failure / An SSL error has occurred and a secure connection to the server cannot be made.” I also cannot access the server via the web interface, though I can Remote Desktop to a PC on my local network and access the server interface from inside my local network.

Running this on a Synology server at home. Bonjour enabled, showing one IP address, and I have tried both automatic and manual port forwarding. Any ideas?

Does load in Safari?

No, it doesn’t. Also doesn’t load in Safari if I go directly to the external IP at port 8089 (which has worked in the past for me).

What if you disable Remote DVR on the web page, then reenable

Try the port checker tool: Accessing dvr remotely

If that’s not working it means your port-forwarding isn’t setup correctly.

Thanks for that link - it looks like I have a port forwarding issue. I’ll head down that path. I appreciate the quick response! You guys rock!