Synology DSM 7.0 and CHANNELS DVR

Can you screenshot what this looks like? Maybe you can ask Synology since its their apps interface that's saying this. I have not heard of it before.

What happens when you uninstall the DVR in the apps interface? Is it still listed there?

If you enable SSH/SFTP on your NAS you can go into and delete (or rename) this folder:

/volume1/@appstore/ChannelsDVR/

Your recordings and backups are stored separately in a share, and you can use those to restore after you reinstall the software portion.

When I look in the @appstore folder after I uninstall the Channels app, there is no ChannelsDVR folder. When I try to install it again, the folder appears.

This is what happens when you install it and get the error:


When you click Uninstall, it disappears along with the folders in the @appstore folder.

What do you see in the ChannelsDVR folder after installing?

Do you have a share called ChannelsDVR already?

On the root of the volume1 there is a ChannelsDVR folder with all of my data.

There does also seem to be a ChannelsDVR folder in the @apphome folder that it says I don't have permission to go into.

It should be @appstore not @apphome.

Can you try renaming the ChannelsDVR share you have to something else, then reinstall the SPK and see if that works?

Unfortunately I'm not a Linux guru. The ChannelsDVR folder on the root of volume1 isn't a share, it's just a folder (it never was a visible share in the Synology DiskStation). There doesn't seem to be a "rename" command in the Synology Linux. I Googled and it said you can also use the "mv" command, but I get Permission denies when I try to use that (I'm logged into SSH as Administrator).

Sorry I meant go into the Synology NAS shares interface and rename there.

But it's not a share in the Synology interface (and never was). How can I view the root "volume1" in the Synology GUI?

Ah then that is the problem.

It was never an actual share, and the interface can't see it.

I think you're SSHing as your own user instead of admin. If you do it as admin, you should be able to mv ChannelsDVR ChannelsDVROld and not get the permissions error.

You might be more comfortable using an SFTP client instead.

I'll try SFTP, but as you can see by the screenshots above (in green), I am logging in as Administrator.

Try sudo mv ChannelsDVR ChannelsDVR2

That worked to rename the folder, but I still get the same error when I try to reinstall the 1.1.0 package file. Should I try to rename all of the ChannelsDRV folders in the @appdata, @apphome, @appconf, etc folders?

Wait... even though I got the error this time, it did seem to actually install. How can I now restore the data from the renamed folder?

Okay good. Now you would need to move all the data from ChannelsDVR2 into the newly created ChannelsDVR share that appeared when you installed the package. That one should be visible via the NAS interface.

Yes, that folder does show in the filestation interface. But since I can't see the ChannelsDVR2 from the interface, how do I move the data? Command line move command again?

yea SSH or SFTP to move the contents over

Ok, I stopped the service, moved all of the folders from the ChannelsDVR2 folder to the ChannelsDVR folder and restarted the service. I can now get into the admin settings but it doesn't have any of my shows or settings. How do I restore all of the previous shows and configuration settings?

See the doc from earlier

Basically via http://x.x.x.x:8089/restore

Thank you VERY MUCH for your help. Thank worked! Next time I will leave good enough alone and not try to upgrade the Channels app if it is working. You might want to put a note at the top of this thread so no one else makes my mistake and tries to install the "newer" 1.1.0 package after upgrading from DSM6 to DSM7.

2 Likes

Glad you're back up and running!

The old package required you to make a share before setting up the DVR. This was confusing and some people ended up with hidden folders not visible from that NAS interface, like you did. Atleast now we have an idea of what happens in that scenario and what steps are required to fix it.

On the plus your setup is now fixed and you can browse your recordings via the Synology interface now to add imports or download recordings.

1 Like