Ubuntu chromium snap error

I used the troubleshooting section to install chrome as well, but that version of chrome doesn't work with the YouTube TV login.

Which TVE provider are you using?

This what I get with YTTV and the channels installed chrome:

If I manually install the latest version of Chromium, YouTube TV login works fine until the snapd error shows. This is why im wondering if the Channels installed chrome needs an updated installer

Been running Channels DVR on Ubuntu Desktop 22.04 with YTTV under TVE for many months. Not a single problem. Install Chromium from Flathub

1 Like

You can see what version of chrome Channels DVR is using by looking at the DVR log.
2023/10/10 18:40:23.082150 [TVE] action=version product=Chrome/109.0.5414.74 jsVersion= protocol=1.3 revision=@e7c5703604daa9cc128ccf5a5d3e993513758913
2023/10/10 18:40:23.084050 [TVE] action=page_ready chromeVersion=109

1 Like

Good call, thank you. The logs show the channels installed Chrome is coming up on 2 years old:

[TVE] action=version product=Chrome/97.0.4692.56

I'll try the Flathub install. Thanks!

1 Like

That's why I moved my 4 Channels DVR servers to docker containers.
Had issues with v97. Docker container uses v109.

1 Like

Alright so the Flatpak install of Chromium doesn't run on Ubuntu server, and seems it's because Flathub apps don't work in a headless environment.

So I ended up skipping Chromium and installed Google Chrome browser instead, and it's working perfectly at the moment. Snapd is still disabled.

I installed it using the following commands:

sudo apt update
sudo apt install wget
wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
sudo apt install ./google-chrome-stable_current_
amd64.deb xvfb

And just like that, TVE works with YouTubeTV again :raised_hands:

Yeah, sorry about that. I forgot the devil in the details. It's not a server issue, it's the headless part -- either server or desktop. And, it's not all Flathub apps, only the ones that need to access the keyring. Same goes for Snap apps.

When you run headless, the password keyring is not unlocked unless you log in. The Flathub version of Chromium won't run until the password keyring is unlocked. The Snap version of Chromium doesn't need to access the password keyring so will run at boot. In my case I run CDVR under Ubuntu Desktop running headless/auto-login on a sub-$100 mini-pc. The mini-pc is dedicated to CDVR and not used for anything else so I took the password off the default keyring so the password keyring is unlocked at boot. The flathub version of Chromium will run at boot.

Thank you this worked for my new setup.

1 Like