V12.12.109 breaks playback on Sheildtv

Playing live tv or a recording reatarts the Channels app and says "Preparing your TV"

I tried lowering resolution and disabling surround sound. No effect.

Was working last night so I assume it must have been something in this version.


Same problem here on my box.

I'm having the issue as well. Sent diagnostics from my Shield. Choose a channel and it "reboots" to setting up your tv screen. Won't play any channel.

Definitely a problem happens on all my Android devices.

Also having the same problem on my shield since this morning

Taking a look. Can you try the new beta?


Just updated to version 12.12.1728

Seems to have fixed the issue ! :slight_smile:

1 Like

Where did you get that. The latest one listed in the beta forum is 12.12.0138 and that is what I have. Still broken with .0138

update your beta ... setting - support - update beta

It's a client update not server.


Got it. I thought we were talking server. Thanks

Problem solved

1 Like

That works for me too, go to Play store to update.
Thanks Great Job!

1 Like

Is this being pushed to Stable? Seems like a big deal???

The crash was limited to beta and does not affect the last stable release.

1 Like

Gotcha makes sense now!

I don't think this is true. I am on 4.5.1 on my shield and is causing this issue. No update available through the play store. Submitted diagnostics about an hour ago.

Any updates on this, what client version is the fix in?

Did you try the beta?

1 Like

I did not since you said the crash was limited to the beta. I will install and let you know if I am still experiencing it.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.