Access remote HD Homerun

Make sure there is no space between = and the long cookie string. Sometimes when you paste in the cookie it adds a space that breaks it. Make sure you are not connected with a vpn or anything to your home network

You're going to have a better time across the internet to not use format=ts and use HLS. It will handle momentary disruptions and latency spikes better.

what would the link look like with HLS as an option? and having a specific channel of 5.1 selected?

1 Like

devices/ANY/channels.m3u?codec=copy should do the trick.

Thank you, I have it working. How long does the cookie last?


29 days for me. But then all you need to do is update the url with the new cookie. Pretty easy

Thank you all for the help with this.

If you don't want to worry about the cookies, consider using Tailscale on both of your DVRs — they'll be able to talk to each other on their private 100.x IPs without worrying about the session cookies.

I tired that and I would start to encode and then stop for some reason. I will test that again today and let you know as I setup Tailscale last week with this project. Thanks @eric

I get this error then I place the TS IP on my DVR in there:

invalid source url: Get "https://100.67.??.??:8089/devices/ANY/channels.m3u": context deadline exceeded (Client.Timeout exceeded while awaiting headers)

Try http instead of https ?
Or remove the :8089 ?

I don't know. I tried every combination of http, https, with and without port number, same error,

And if it worked, I doubt the TS IP address would be in the returned m3u for each channel.

I turned off tailscale on my Channels DVR servers running on my two Synology NAS's.
I then installed and ran the Tailscale package on each Synology.
I still get the same error attempting it from one Synology to the other.
context deadline exceeded (Client.Timeout exceeded while awaiting headers)

Maybe @eric can look into it

1 Like

Can you reach out to Tailscale support and see if they can figure out why it isn’t working on the Synology with the OS package?

Works from my Windows 10 PC with tailscale when I download the m3u from Channels DVR using its built-in tailscale. Of course you cannot specify a port.
And the TS IP is in the m3u.

Just doesn't seem to work between the two Channels DVR servers.

@webcds What are you running your two DVR servers on?

So here's what I found.

Tailscale maintains the Synology packages, but has to submit them to Synology for it to appear in the Synology Package Center, which had the old version 1.22.2 that I was running.

Found the latest stable v1.32.2 package at tailscale and installed it.
Then I found the reason for the issue Enabling Synology outbound connections - Tailscale but I'm not going to do the workaround right now that requires running commands at boot time and anytime the package is updated.

By default, Tailscale on Synology with DSM7 only allows inbound connections to your Synology device but outbound access is not enabled.

1 Like

Thanks for the info @chDVRuser I am on DSM7 so that is the issue then.

1 Like

If you're interested, the latest tailscale built Synology packages are here

Thake you @chDVRuser for that link, I am thinking about just moving the DVR to my Mac mini M1 for better speed, just a thought.

@chDVRuser Thanks for the tip! This is very helpful. I hadn't been able to figure out why I couldn't connect out from my Synology.


Just tried between my two Synology NAS's after implementing the workaround.
Works fine when using the Synology Tailscale package on both.
Tested by using curl from one NAS to the other NAS.

curl -v "http://100.x.x.x:8089/devices/ANY/channels.m3u?codec=copy" -o "/volume1/arkives/playlist.m3u"

Next test is using the Channels DVR built-in Tailscale on both.
Not sure if that will work without being able to Add CAP_NET_ADMIN to the Channels DVR Tailscale binary, or maybe that's only needed for tailscale configure-host ?

Nope, doesn't work using the Channels DVR built-in Tailscale and there's no tailscale binary, so not sure how this will work unless users want to run the Synology Tailscale package and implement the workaround.