All client apps crashing on launch

Both Apple TV and iPhone are crashing on launch when trying to connect to my DVR. All on latest prerelases/betas but the App Store versions are crashing too. Happens locally and remotely. Sent logs from my iPhone.

Strangely, the web interface works fine and I can watch all of my channels in browser. I'm guessing this is a problem with the latest server prerelease or some very weird network issue has sprung up on my end.

Edit: Also, I've tried everything I can think of short of rolling back to a previous version of the server. Restarted my NAS and clients completely.

Can you submit diagnostics from the web UI


Thanks. The crash should be fixed in the next TestFlight, which also has increased logging about what's going on. Seems like one of the channels from your custom M3U sources is not being parsed correctly. Perhaps the international characters.

1 Like

Yup that fixed it, thanks for the quick response. Although I find it strange because I haven't had a problem with the previous releases and traditional Chinese characters.

Please submit diagnostics and I'll see what channel is causing the error. It will be missing in the app.

1 Like