Android Mobile Client Video Cropped

I've got a Samsung Galaxy S21 5G Ultra. When I watch anything in landscape mode the top and bottom of the video is cropped.

Is there a way to fix this? I found the Stretch video to fit option, but that's not what I'm after.

Thanks in advance.

@tmm1 - is this an issue you're aware of? Just wondering if I'm missing something obvious :slight_smile:

Yea this is an embarrassing bug. I'll try to figure it out soon.

1 Like

No rush - it's not a big deal. Just a nice to have.

At least on my phone the issue is that the aspect ratio is wider than 16x9. The playback appears to select the scaling factor based on the width alone. (Think of the three options when viewing a pdf, fit to height, fit to width, and fit page.) I don't know if you feed it into something that handles it all for you or if you calculate the scale factor yourself. If you do it yourself, then you should just add a calculation for it from the height as well, then choose the smaller of the two. (You may then have to move the result over to center it if that isn't done for you.).
If it is an API you don't control, good luck... My programming is normally done on systems where we have to build most things ourselves without fancy APIs. Sometimes it is annoying, but we have full control.
I just took screen caps of it to make a post two minutes ago and saw this. I guess I don't have to post the picture of the score cut off from the game.
Thanks,
Josh

I don't use my phone often, but I was just using it now.

Interestingly after a few minutes in landscape mode the video suddenly dropped down to the correct size.

1 Like

I just checked on mine and in the time I was watching it didn't fix itself, but things have gotten worse than before. Right now, my 21x9 aspect ratio phone is stretching it all the way across, but has black bars on the vertical. Which means that it is more distorted than just scaling in both directions. My phone is set not to stretch, so the old behavior was to crop off the top and bottom of the video.

Yes I'm seeing the same behavior now. The beta version still has the old behavior though.

@tmm1, hi there, I know you're busy with lots of cool new features, just wondering if this issue will be sorted? Thanks!

Things are working for me with the Video Decoder set to Hybrid or Software. I get a squished screen on Hardware. Are you seeing something different?

I happen to be running the Beta if that matters.

2 Likes

Oh brilliant! I didn't realise that setting existed. I've just set it to Hybrid and it's looking much better :blush:

1 Like