API doesn't seem to respond to any POST commands?

Hi all,

I'm hoping to build an automation with Shortcuts, to fire up the Apple TV, open Channels, switch to a certain channel and then pause it (so we can watch minus ADs) - but the API doesn't seem to respond as I'd expect.

If I enter into my browser, the API responds correctly with a list of the favourite channels. The same works for the status API call.

But when I try to access any of the other commands, such as:

I just get the page reloading with the list of commands again, with no action happening on the Apple TV. There also isn't anything that seems to appear in the log either.

Can anyone help?


So, I've worked out that I didn't quite understand a CURL request.
However, while I've worked that out, the command still doesn't appear to change or select a channel:

curl -X POST


{"status":"playing","muted":false,"channel":{"number":"14","name":"TVSN","image_url":"http://img.hdhomerun.com/channels/AU430637.png"},"now_playing":{"title":"Solidtecknics AUS-ION Cookware","summary":"Solidteknics Cookware believes in creating a sustainable industry where cookware is not disposable. It can be used in both professional and home kitchens which makes it the perfect fit for all.","image_url":null}} %

It continues to play the existing channel and doesn't change it.

Try without a space between -X and POST