Apple TV / iPad "On Later" not functioning correctly

Hi there, new user / subscriber here!

I am just setting up Channels DVR for the first time today alongside a newly purchased HDHomeRun, using my DS920+ as the Channels DVR server. The DS920+ is also a fresh install. I have several devices in the house which i'll be connecting, but initially i've set up my Apple TV and iPad Air.

I've set everything up, made sure channels is up to date and added the guide (I put my postcode in and chose 'freeview'). Once I did this, the database did it's work and downloaded the guide over the next 10 minutes or so.

Once complete, I installed Channels on my ATV and iPad.

At first, I thought everything was working great, however I noticed two issues.

If you click on the channel icon in the guide (which should bring up the 'on later' content for that channel), the content flicks up briefly, it then disappears and comes up with the error "It doesn't look like this channel has anything available". This happens on all channels and affects both my iPad and Apple TV. This is consistently broken for me.

On the web front end though, if I bring up the guide and click on one of the icons in the same way, the 'on later' content for the channel loads and there is no issue.

Secondly, the actual 'on later' option on the Apple TV (from the sidebar), is also not working - when you click on it you get the error "Nothing seems to be on...later.". On the iPad, it behaves a bit differently, it initially flashes up with the aforementioned error, but then loads the content. But after it loads, if you click on another option such as 'library' and and then on 'guide' again (which should load the 'on later' content') you get the error again. If you click on 'guide' at the top left and then 'on later' at the top right, it will initially error and load once again. A lot of the behaviour is predictable and easily replicated.

Again, on the web front end, all works fine.

I have already tried a delete and recreate of the DB. I also removed the guide and started again with that. I also removed channels completely, deleted all folders (as this is a new install) and started again from scratch. I've wiped the apps and data off the devices and installed them again, but I get the same behaviour every time. I've left it for several hours in case the DB was doing anything in the background and needed to finish, but no difference.

I have also tried the pre-release version but it behaves in the same way as the stable release from a couple of weeks back.

I couldn't find any other posts relating to this issue on the forum, except this one from just a couple of weeks ago:

This also mentions exactly the same issue, on the 3rd post and 8th post.

So i'm wondering if there is a bug here.

I don't know enough about Channels yet to know if this is an issue on the DVR side, or the app side.

Anyone have any suggestions?


1 Like

Uploaded DVR diagnostics with ref:

I also uploaded iPad and ATV diagnostics.

Yes it sounds like a bug

So, curiously, while I have been experiencing the above issue all day, I hadn't actually scheduled or started any sort of recordings yet.

So I started playing around with that on the ATV, recorded a couple of things, set up a couple of series links, that kind of thing.

Then the 'on later' and clicking through on the guide channel icons started working. On both iPad and ATV. I believe a few folders were created in the Channels share when I started playing around, which weren't there before. Logs, Movies, TV I think were all created. Now, i'm not sure if this is related but does the 'on later' functionality rely on some of all of these folders being present?

Or maybe there is another file that gets created, modified or perhaps something in the DB changes when recordings are made, and this makes the 'on later' stuff work correctly.

It's probably something else, I honestly have no idea at this point - and I can't say for 100% that doing a few initial test recordings actually made it work, but it is awfully coincidental.

Will keep an eye on it. For the purposes of testing, if it helps, I can always completely wipe out channels again on my server, reinstall and see if I can replicate more accurately. I'm pretty certain either doing something in the UI, or making some recordings somehow made things work correctly.

Its a bug. The behavior is random.

Ah ok, no worries. Well that was the other possibility, that it is a random bug and I just lucked out earlier.

Would you like me to submit any additional information to help get the bug resolved for a future release?

Let me know. Equally if you need me email additional diagnostics happy to do so.

I think we tracked this down finally and it should be fixed in the next TestFlight update.

1 Like

Thank you very much for the support! I haven't encountered the issue since I first raised it, but glad you were able to track down the behaviour.