Appletv 4k playback stutter

I have both of my ATV's set for experimental deinterlacer and default audio and video drivers. I have been having an issue with TVE recordings where they have so much stutter that they are unwatchable. To troubleshoot, I played back a TVE recording in plex. It played significantly better than it did with channels (there is still stutter but the TV's post processing can clear up most of it). So I started looking at channels and wondering why it was so much worse than plex. To troubleshoot I enabled the expiramental video drivers and now the TVE recordings look slightly better than plex. Problem solved? ...Not quite.

When I play back an MPEG2 recording there is now a constant stutter where there wasn't before. If I go back to the default video driver then the MPEG2 recording is fine. So if I fix TVE, it breaks OTA. if I fix OTA, then it breaks TVE.

I tried this on my shield and TVE looks good. The problem is that one of my locals causes the shield bug to make the video have artifacts. I have to enable the software decoder to get it to work properly. Problem is that breaks Atsc 3 recordings. So I can't find a platform that let's me do everything I need lol.

Right now on the ATV, I am just watching TVE in plex and OTA with channels but it is a hassle. Is it that the processor can't handle the expiramental deinterlacer and the experimental video drivers at the same time? The expiramental deinterlacer looks so much better than the defualt so I hate to disable that.

I ordered a new ATV so when it comes later this month I can see if it is any better. But in the mean time I am kind of stuck.

1 Like

I dont believe the (noticeable) dropping of a couple frames (specially with audio) should be attributed to the new ATV4K.

It's been worse since the last server update. Enough so my wife is making comments so now were watching in Plex at present. The video (any video) plays just fine in Plex so it's not any of the actual recordings.
Also there is nothing in the error log.

--- update
The default audio & video drivers WERE selected for some reason (I do remember previously setting them to the experiment drivers)

Selected both experiment drivers, the random jitters/audio disappeared.
A problem shows up that after (some) videos play for approximately 7-8 minutes the video then pauses to left the remux update, then repeats this every 45 seconds or so until a commercial break (automatic commercial skip occurs) then channels is happy again, unless a commercial takes longer than 7-8 minutes when the remux pause occurs again.

My thinking is that there is a buffer full of some sort on the experimental video driver (so to test, and it so far the below settings appears to fix these issues) was to set to

AUDIO driver: Experimental
VIDEO driver: Normal

So far so good

FYI These are both 4K TVs with 1 new and 1 older AppleTV 4K boxes

I'm not sure what you mean by remux here.

Is there a spinner on the timeline when the video pauses? That would suggest buffering.. and I'm not sure why changing the video driver would make any difference to buffering.

Please try TestFlight beta build v6.17.7

It should improve the stutter issues on the Experimental video driver.

1 Like

It appears that the stuttering i was experiencing has completely vanished using the updated video driver!

Watching the same video i described the issues with the experimental video driver now works perfectly.

It no longer displays (I forget the term that was displayed: mux, remux something like that) in the STATUS -> ACTIVITY section of the server using the video I know had these issues.

It's fixed, thank you.

1 Like