Audio stuttering glitch with HomePods home theatre and Channels app

Hi there,

I have an Apple TV and stand-alone channels for HD home run app, with audio running through HomePod home theatre mode. My Apple TV is gigabit Ethernet connected.

It was working flawlessly until a few days ago.

Now when changing channels, after about 7-10 seconds there’s a micro stutter in video, followed by a second or so of stuttering audio, then back to normal. Also when I close the app, or go back to the guide, audio keeps playing longer than it used to.

I’ve tried both experimental audio and video drivers, turning match frame rate on/off (in app and system settings), turning off surround sound in app settings. I’ve reinstalled the app, reset Apple TV. Reset HomePods. Setup as new again. Still same issue.

No issues using any other apps. And if audio routes through TV speakers there is no audio stutter glitch at all, and channels seem to change faster aswell. iOS apps work flawlessly so I don’t believe it’s HDHomeRun. Just channels on Apple TV running through HomePod home theatre.

Has there been a bug introduced in most recent channels app update?

Can anyone help? Or suggest other settings I should look at?


If nothing else has changed, I wonder about network. Mine has been rock solid for years, but now I have unexplained slowness from time to time and a reboot fixes it for a while. Probably time for me to think about replacing it.

Thanks for the reply. I can’t see how it would be network related if none of the other apps on Apple TV are having the same audio issue.

The network is comfortably pushing ~ 400mbps internet around to all clients so HDHomeRuns 10/100 speed is trivial.

Little glitches effect differs apps in different ways, especially with WiFi. My living room connection is wired and never has a problem. My other divides each have to be tweaked to deal with their unique WiFi reception issues. Of course, you may be dealing with some entirely different.

Unfortunately, using HomePods has always introduced a little bit of lag or slowness with Channels when you skip or change channels. 7-10 seconds seems excessive though, and it shouldn’t still be playing after you leave the app. Has your router been updated recently? Or did you update your Apple TV or HomePods?

I’d you haven’t seen it already, this thread sums up a lot about the HomePod experience with Channels.

Hey thanks for the replies.

So I managed to fix it. The issue was that last week our ISP changed and supplied a new modem. I placed the existing Unifi Dream machine AP/DHCP/NAT gateway behind this new modem (so as to keep exisiting settings, as ISP modem doesn’t allow for bridge mode). Both networks using different subnet. Every other use case and client on network including Apple TV has had zero issues. So thought everything was fine.

But removing the Unifi dream machine and running straight off the ISP supplied modem has fixed it. Channels + HomePods must not like the additional hop to gateway. But I can’t understand why? Happy it’s working though.

1 Like

It may be worth investing in your own modem if that's the only way to get bridge mode. It's only a matter of time before that crappy ISP provided modem/router causes you more problems.You're much better off relying on your Ubiquity equipment.