Audio video not syncing

I am having issues with audio being out of sync. It seems to get worse as content plays.
My equipment is as shown here:
Firestick 4k, 2022 DS902+, my sound is coming through a Visio 5.1 sound system with sound bar connected through my Roku tv. I have read all the issues with Roku but that is what I have.
All hard wired to UniFi network.
Any ideas what I can do, I have tried all the setting I can think of and those I read about on this site.
If I was sure Apple TV device would stop this issue I would not have a problem replacing my fire tv with apple 4K.
Any help would be appreciated. This is very frustrating.

1 Like

Submit diagnostics from the app and we can take a look if there is any obvious issue.

Did you try in Settings > Playback > Advanced > Surround Sound: Off

Yes, I turned it off and back on again. How do I submit diagnostics?
I am pretty new to the software.
Thanks

I searched for submit diagnostics and found out ow to do it.
I will submit diagnostics when I get back home tonight.
I have remote connection turned off.
Thanks

Aman,
I have submitted the diagnostics as requested.
Please let me know if you find anything or if there is something else I can do to get this working correctly.
I really like Channels approach and will put out great effort to get it working, just don't know much about this or what to do.
Thanks

I need diagnostics from the client device. You have to submit it on your TV. After you replicate the issue

Oh, ok. Will do.
Thank you

Do i need to pick video player as the issue?

Yes that's fine

1 Like

Ok done, I was able to replicate by simply fast forwarding through the movie, it gets gradually worse as the movie progresses.
Maybe I should transcode (hope that's the correct term) into another file format.

All I can see is a bunch of fast forwarding. Please play for atleast one minute with the sound out of sync, then exit the player and submit

Ok done, Thanks let me know if you can see anything this time.

I see a bit more but still not getting all the info I would like.

Please go into the FireOS settings under Apps and force stop Channels. Then replicate again and resubmit

Done, but I do have to leave now. I will check to see your comments when I return.
Thank you Aman

Thanks. The playback looks fairly normal from the logs. Can you describe the behavior? Does it start in sync and change over time? When you submitted was it out of sync? How much is the sync off by? Does it happen on every recording or only some local content imported?

EDIT: I see some more details in your email to support

I'm not really sure what's going on, but I am fairly confident you wouldn't have this type of issue on the Apple TV.

Thanks Aman, is MP4 an ok file type for this service or should I transcode to something else?
I am going to check and see if my recorded TVE movies get out of sync. I think I remember them doin it as well but not as much.
By the time I am 3/4 of the way through the movie of the MP4, the sync is a couple of seconds. Way off.
I’ll do some more testing and maybe get an Apple TV device. Do I have to have an apple 4K?
Once again thanks.

mp4 is fine. The 4K model has a much better CPU and what is recommended.

It looks like my MP4 file is not a quality recording., I check it out with WMP and it is jumpy and doesn't play well, my other MP4 files are similar, the ones that play well in Windows Media Player are also good with Channels, the ones that are not so god in WMP have a sync issue in Channels, so I think I have some corrupt files.
I am going to consider this matter settled until I have any other problems.

I do have a question though:
Do you recommend my TCL Roku TV be setup for PCM or Dolby Digital Plus?
Thanks and I am sorry for the wild goose chase.