Automatic Commercial Skipping Bug

I record a lot of programs from my PBS stations. Of course there are no commercials on PBS. All of the ads for other programs are at the very end of any given recording, so I simply stop watching PBS recordings when the program actually ends and before the ads for other programs begins. However, commercial detection detects commercials on PBS, so whenever I watch a PBS recording, I have to turn off automatic commercial skipping.

Even when automatic commercial skipping is set to MANUALLY, the Channels player skips the bogus commercial at the beginning of every PBS recording. I then have to PAUSE and back up to see the part of the recording that was skipped, which is part of the program I want to watch. When automatic commercial skipping is set to MANUALLY, it needs to apply to commercials detected at the very beginning of a recording as well.

I would appreciate it if you could fix this annoying bug as soon as possible, as it is present on a large percentage of my recordings. Thanks.

1 Like

OMG YES! I record lots of PBS as well and unlike other channels there are no commercials interspersed through out the shows, but AUTO SKIP turns the program into Swiss cheese!

Please fix this folks!

You can tell the server to:

  1. Disable commercial skipping on a per-program basis
  2. Disable commercial skipping on a per-channel basis

The former is available from the DVR's Library > TV Shows section in the web UI, while the latter is not exposed in the UI, but can be configured from the command line.

Thanks, I'll ask my computer engineer husband to implement the latter as I have no idea what that means. :wink:

Here is the relevant post regarding disabling on a per-channel basis (it took me a while to find it):