Manual Recording with no ComSkip

With the latest Channels DVR Beta installed, my ComSkip is finally working as it is supposed to do. I have a 3 hour manual recording every day on Fox Business. It needs to be manual so I can tinker with the start and end times. After the recording, Channels does a ComSkip run, which is my default.

However, ComSkip does not work on Fox Business TVE, so my CPU is grinding away on a 3 hour recording with no useful results.

I would like to be able to specify that this particular manual recording should not be ComSkipped as part of the initial manual recording request.

Give the recording request a seriesID on the JSON payload, then after one recording go to the series' page in the DVR to turn off commercial detection for that series.

Great, I'll give it a try.

One option I'm considering is a list of channel numbers for which comskip will be skipped. This has been requested by @Robinlmp and other UK users in the past. Would that work for your usecase?

6 Likes

The option for pre-selecting channels (UK) to not comskip would be good... yes please.

Yes, that would work for me. The only reason I don't ComSkip is because it doesn't work at all on some channels, and is not needed on PBS where there are no commercials.

I didn't get a chance to add a UI for this today, but the API backend is there in the next prerelease.

For example, if channel 1009 is PBS:

curl -XPUT http://x.x.x.x:8089/comskip/ignore/channel/1009

4 Likes

Great! I just added 5 channels. I'll see what happens in a few hours.

Ken

I added Channel ID's and it did not seem to work. Then I added real channel numbers and it now seems to work.

Is there a way to remove the wrong numbers I put in?

Thanks much for this WONDERFUL feature.

Ken

Did you try
curl -XDELETE http://x:8089/comskip/ignore/channel/1009

I never used -XDELETE before, so I gave it a try. It reports success no matter what I send, so there is no way to know if it actually did anything.

Ken

What about GET /comskip/ignore/channel? Or any path further up the chain?

I haven't used that new option yet, but check settings, they should be in there.
http://x:8089/settings
I just verified that's where they are

Yet another problem solved. Yet another thing learned.

You guys are GREAT!

Awesome. I was just thinking about this the other day. Hoping for the UI portion soon :slight_smile: