Beta 121 Goes Into "Search" When Passing Over It (DVR)


#1

When you are scrolling though the menu on the left-hand side of the screen and (try to) pass the “Search” selection under “DVR,” it goes into Search, requiring you go left or hit “back” to continue through the menu.

Priority: A minor annoyance.

ETA: AFTV Beta 122 does the same.


#2

This is a known issue with the android search widget, which likes to steal focus as soon as it is made visible. I’m looking into workarounds.


#3

I noticed this too. I meant to make a thread about it but kept forgetting. I am glad someone else has. Usually I don’t go that far down the menu on a regular basis but it is annoying on those times I do. lol


#4

This could be the same issue, but I’m seeing it on the Fire TV Cube too.


#5

This is fixed in beta v123


#6

This phenomenon was irritating. Will be glad to see it resolved in latest beta 123.


#7

I just updated to Beta 123 and this still happens for me. I am on the Shield device.


#8

Does the About tab say v123? Are you on Oreo?


#9

Yes. The tab says v123 and yes I am on Oreo.

I also restarted the Shield device when it didn’t work the first time and tried it again. Same result.


#10

For some reason the Play Store is not updating my installation automatically. I’m having to uninstall and re-install it. Now have v123 on my MiBox 3 running Oreo. Search is still capturing focus if you pass over it too slowly. If you move past it quickly, it does not.

(testing…) Seems if you pause on it no more than about a second or so it won’t grab focus.


#11

Okay I tweaked the fix some and it should be better in v124


#12

Indeed it is. Now you have to actually click on Search to get the search bar. Thanks!


#13

Yes, same here. It doesn’t jump over anymore! Thanks!


#14

Does the app utilize Universal Search from any screen to jump to and tune to a channel by name? I haven’t tried because I didn’t know if there was a specific set of commands to use.


#15

AFAIK the only APIs available for the new Google Assistant are for search results. The universal search can be used to bring up matching DVR shows.

Using google assistant for commands seems to be restricted to certain system apps like Live Channels only.