BETA: Automatically Skip Commercials

I noticed today when we went to watch one of our recordings that the video was showing a solid purple line with no cuts. I went into the web UI and selected it to cut them again and the entire video was checked. I re-did the cuts, hit save but it's not saving. It acts like it is, but it isn't.

Out of curiosity I looked at the 4 other recordings I haven't manipulated yet and all of them are now showing no commercial cuts. However, one recording that we were mid watching from a few days ago does still show the cuts. It seems to only be the ones I have manually cut and saved.

Can you update to latest and try again?

I had to step out for a bit and just got a chance to try it again after updating.

It seems to be working fine now. Thanks!

1 Like

I also have been removed from the tvos beta I also do not have an iphone or ipad, would love to beta test this feature so is there any chance i could be reinvited please.

For some reason, I was removed from the beta testing program. I am curious as to why that happened? Nevermind, figured out what to do, LOL!


So when will this feature make it to final release?

I just tried it tonight while watching the second episode of American Idol, but the skipping was way off. At one point it shipped ahead while a contestant was talking to the camera. I need to read back through this thread to see how to tweak it.

I have noticed that using the double tap to skip through the last commercial break does not work in the latest beta. I understand the reason for not auto skipping the last commercial break, but I would think the manual option should still work.

I think this is absolutely amazing!!! Love it!

Does the new Beta load automatically? If not how do I check if I have the updated Beta?

I downloaded this to my iPad and watched a few different recordings with different content (news, drama, sports, cooking) and it worked great! The only thing that I noticed is for shows that do a teaser before going to commercial, the last couple of seconds of the teaser was clipped, but that is not a big deal for me!

I may add this to our family room ATV4 and give it the wife test :open_mouth:

Can you be more specific about the case that's not working? A photo of the timeline would help.

We specifically disabled the case where double-skipping would take you to the end of the recording, because that causes the player to exit, mark the recording as watched, etc, and its really hard to find the recording again and go back to where you were just to watch the remainder that got accidentally skipped.

Based on your response, I think we are on the same page. When the cursor is in the last commercial segment, the non-beta version allows the double tap to skip to the end. I know why you would disable the auto-skip in this section of the recording, but it seems like you would still allow manual double tap to skip if the user wishes just like we can focus in non-beta.

Okay, I understand what you're saying but the problem is if you pick up the remote and double-click without looking at the timeline first, you can end up accidentally closing out the player which is a really terrible experience.

Hopefully as we start to roll out improvements to the commercial detection this won't matter anymore.

Not sure if this has already been reported, or if possibly it is by design, but ...

I use a Harmony remote. Commercial skip works great first time through, but if I rewind back to an earlier part of the show, commercial skip does not happen when it gets to the commercial breaks.


That is by design. It allows you to rewind and watch something that was skipped incorrectly without automatically skipping it again.

1 Like

Finally loaded the Beta to my FireTV from my phone via apps2fire.

I've watched a couple of shows with the beta. If I manually skip within the show or turn off the auto skip and double tap through commercials, it takes a long time (2-5 seconds compared to instantly) to start playing again compared to the non-beta. Occasionally it starts up instantly, but not often.

It's a great feature, but the delay makes it worse than manual double-tap.


Could not find its own thread, so adding here. Been using the Skip Commercial button on BETA. Challenge comes in when it skips too far ahead (commercial markers are off). Then I need to back up. I click back (with Apple TV remote), then the skip commercial button appears again, and if I try to go back any further then is skips forward again as I have hit the skip commercial button again inadvertently. This is a vicious loop that cannot be broken unless I pause and scrub to where I need to be.

@Phillip The issue you described is fixed in the newest beta.

Awesome thanks for the quick response. I will test it out.