Beta on-later crash

The two most recent betas crash when accessing onlater on my atv. Non-beta app does not have this issue. Diagnostics sent.

Just visiting the section? Or were you navigating in some way. Could you provide a way to reproduce it?

Please try the latest TestFlight beta. I took a blind stab at what might be the problem.

It does not work for me. If i open the atv app, select on later, atv goes back to atv app menu. If I try to open Channels again immediately after, it starts to launch then goes back to atv app menu. Try a third time and app opens to guide and works as long as I dont select on later again.

This is repeatable for me on the latest beta.

I just submit diagnostics again, but dont know how useful that is seeing that I need to relaunch the crashed app to send the diagnostics.

I'm hoping that the latest TestFlight beta going up right now (2022.08.04.1743) will resolve this. Let us know!

It did not work, using latest beta.
It is not random crashes; it crashes every time I try to open on later from the beta app and happens on multiple atvs.

Please submit full diagnostics from your dvr.

This is a huge mystery.

Some time after excluding some ip camera m3us from fine tuning on the dvr server, on later has started working again. Im not sure why only the beta app caused an issue. But I just was able to open on later from the beta for the first time in awhile I am able to use it from the beta. i tried it on 3 different tvs just now. But I will submit dvr diagnostics if maybe it helps to see the m3u that may have been causing this issue.

Hmm, those m3u cameras don't have any guide data attached though, do they? Not sure how it would be affecting On Later if it didn't have guide data.

Thanks for narrowing down the issue. The beta uses a new apple API for rendering lists and is being triggered by this condition. We plan to release beta to stable this week so its good to hear this is not crashing for you anymore.

Do you have any manual recording setup for those IP camera m3u's?

@tmm1 If so, maybe related to this Javascript error doesn't go away

No recording through channels, no guide data afaik. But it was repeatedly crashing on later on the atv. And only on the beta. All I know is that after I explicitly excluded these m3us, on later worked a few hours later.

OK, I think we finally got it fixed in the latest pre-release. Please check it out and confirm!

It has been working recently and I am not sure what caused it before that I can replicate. I did try removing the excluded m3u channels. And It does still work. You may have fixed it.

It was fixed on the dvr side