BTN / BigTenNetwork unable to correctly play recording


My recording is happening now while the game is live.

Symptom = If i play the recording either from the start or the option to resume, I get a minute total of 1,532 + minutes on the scrubber of the DVR GUI. It's as if the recording "timer" starts at 1,532 and takes off from there for a 2hr game.
Additionally, I can't scrub on the timeline to catch up or resume. I can skip forward, kind of, until a commercial "blocks" or stops all progress.

Logs are: 92c75a8d-939d-4b84-865a-087c7a459a01

I'm running:
Raspberry Pi4 v 2021.1101.2046
Pre-Release v 2022.01.09.0153
Apple TV 4K TVOS 15.2
Seagate One Touch 2TB USB 3.0 External HDD (yes, externally powered. not via the RPi4).
YouTube TV; Channel 6199 BTN

ok. the recording just took me back to the beginning again.

too frustrating. back to youtube tv app for right now.

let me know how i can help resolve this.

Sounds like you need a more recent pre-release. Issues with BTN were fixed in a later release:

Yeah, sorry. I just edited my pre-release above.

I did update earlier this morning as well. And earlier in the week with another issue from the same TVE channel there was also a fix w an update i applied.

I can watch the game LIVE. Things just get weird when i play the recording.

Odd because there was success with 2 or 3 other recordings from the same channel earlier in the week post-update.

Please send us the recording and we can take a look.

So I'm dumping the entire 5gb file to you? Just making sure.

Also looks like it only recorded 54minutes of a 115minute game, despite being a similar file size to other 120 minute college basketball games.

Can you first try doing "Fix Video Timestamps" on the web UI to see if it resolves the duration and other issues

File uploaded. I have fast Interwebs! Give me a few to power everything back up and I'll let u know about your Timestamps request.

"Fix Video Timestamps" resolved my issues while watching the recording post-recording. That's cool.
But what about when I need to catch up during a live game? That's the feature that is most-used to accommodate bathroom breaks and other distractions.

Is the recording marked as interrupted ?

I stopped it early immediately following the end of the game. Web UI says "cancelled". Apple TV GUI calls it "stopped early".

I had this issue today watching The Herd on FS1.
Started watching about 45 minutes in and the timeline was all messed up and if I tried to skip/FF forward or back, it would start over. Same result with both the Kodi Channels add-on and an Android TV device.

Ok. I had issues with TVE ESPN - YouTubeTV last evening. LOTS of timeline freezing and stuttering, and app crashing - i can't remember what the app was telling me. Really a bummer to catch up or rewind, etc.

I power-cycled my $15 TP Link network switch. Recordings have been going well since. I'll record a few games this evening to observe behavior.

gotta love cheap network devices... time for an upgrade.

OK. I'm recording "Rutgers v Penn State" on BigTenNetwork, YoutubeTV, TVE. When I tried to catch up, when only behind 5mins, the timeline just starts behaving weirdly and starts at minute 1562. It also makes scrubbing w/ the ATV touchpad impossible. HOWEVER, I can hold the FF or REW on the ATV remote and that seems to work. That said, this is a weird symptom, and it completely bombed last night while recording the college football national championship.

Logs: 00dc0b85-772b-4ffd-aa27-a33b6f8d8393

Raspberry Pi4 v 2021.1101.2046
Pre-Release v 2022.01.10.1847
Apple TV 4K TVOS 15.2
Seagate One Touch 2TB USB 3.0 External HDD (yes, externally powered. not via the RPi4).
YouTube TV; Channel 6199 BTN

It's doing it again: Just began recording a 120 minute game, then I tried playing the video a few minutes behind, tried to catch up by skipping (not scrubbing), and the recording length now shows 1,532+ minutes or something. Makes scrubbing impossible but skipping forward appears to work. This is not good

I'll check it out to see if fixing the timestamps helps when the evening is done, but this is annoying and not at all mimicking a DVR. We shouldn't have to fix timestamps on the regular or worry about whether or not we can actually watch a recording a few minutes behind.

Please let me know how I can help.

Logs = 9cca8f13-d4ea-42dc-b89d-6902a4a0a49a

I'm trying to see the recording in your logs. What time did you start it?

I got impatient and stopped it. Tried to fix timestamps WHILE it was recording, which just exacerbated the issue and told me it was only 53 seconds long while still saying it was recording. Of course, it wouldn't play at all after that.

I've got Rutgers v. Penn St. from last evening. That one was symptomatic as per my post above w/ logs 00dc0b85-772b-4ffd-aa27-a33b6f8d8393

FYI - I Fixed timestamps for this one, but it still didn't help. It will play in it's entirety, but it didn't fix the issue of 1,500+ minutes so that i can't watch most of the first half. So this would be a good one to look into.

Can you send us the debug recording log from today's recording