Cannot connect

I’m having trouble getting channels to connect on my wife’s iPhone. I’ve just submitted diagnostics from the app. As it can’t even see the server, I don’t think there will be anything of interest in the server logs.

Any tips?

Edit: I’ve now managed but only by disconnecting the phone from WiFi and connecting ‘away from home’ using 4G. Having done that, it now seems to connect locally. Weird glitchy behaviour.

Connection problems are continuing again. It partially connected for a moment. Server is now saying the client was seen recently but the app still will not show the proper interface and repeatedly fails to connect.

In the troubleshooting tab on the web interface it shows this error:

Connected to but SSL certificate is invalid.

I’ve submitted support logs: b0b65d90-994c-4698-bf31-e604ab6b353e

Would appreciate some help here. thanks.

Strange how this is only affecting one device.

Here is what my wife’s iphone shows when it fails to connect:

I know the address is correct because it is working on other devices. Other devices find the server without a problem automatically. Only my wife’s doesn’t and even when the IP is entered manually it still fails.

OK, solved it.

She had the ‘HD home run’ version of the app rather than the DVR version of the app. Most confusing and it was really hard to work this out because there is no indication in the app that I could see.

When trying to connect to a DVR from the wrong app, it would be nice if there was a warning that it wasn’t connecting because you’re using the wrong app rather than just a ‘couldn’t connect’ error.

In looking at the diagnostic logs from the device when it wasn't working, the error message it was getting from iOS was The Internet connection appears to be offline..

I don't have any obvious explanation for why the "HDHomeRun" version of the app would have had issues — they both connect to the DVR the same way.

1 Like

That offline message means the iOS privacy settings were not allowing local network access for the app.

1 Like

Thanks, that would explain why installing the other version of the app worked. Presumably with installing the other app, a new prompt would have come up requesting LAN access?


1 Like

Glad this is fixed. Is there any way to have a notice in the app to say that LAN access has been denied and the app will not connect? I only ask because I hadn’t originally installed the app (my wife had) and trying to fix this I thought my network was badly broken. Spent a good couple of hours investigating.