Can't get out of Channels

This is making me nuts. When I'm in Channels it won't let me out. Let's say I want to switch over to Amazon or Netflix. I try to switch and nothing I do will let it exit Channels. Cannes is still active, I can change within Channels, but 98% of the time I have to unplug my Shield and let it reboot.

Nothing like this on other apps.

I hope I'm just missing something but this makes it tough to switch apps so I can check scores.

Thanks

What all did you do?

What remote are you using? You tried both the back buttons and the home button?

What screen is the Channels app on when this happens?

I'm not sure of the brand of remote. I picked it when I first started because it was recommended.

I'm usually on the guide screen when I get stuck.

I've tried both of those buttons.

When it I get to a point to where it won't let me go any further I unplug the Shield. Just turning off the power with the remote doesn't help. When I turn it off, then back on, it goes back to the same screen, usually the guide, and I get no further. Unplugging the Shield has always worked. It is a pain though.

No matter how long I wait after a power off it doesn't change anything. Once or twice in the history of my using Channels it has locked up on other apps, but that is since I started with Channels, almost 2 years.

If you use the remote with the backlight/triangle shape in the hand. You should be able to double click the O and it will take you to a screen to x out the programs running. It almost sounds like you messed with the mapping of the remote and you changed the defaults to where you can't get back to the main menu. I have 2 2019 shields. The pro and the cylinder one and both do not do what you say they do.

I'm not using a Shield remote...it got washed.:rofl:

It works with the official remote.

So which remote are you using where it doesn't work?

As I said earlier, I don't know what brand it is. I've had it for two years because several here said it was a good remote. There is no branding on it. It has a keyboard on the opposite side from the controls. It's rechargeable.

I got it from Amazon.

Doesn't help us debug.

Maybe check your Amazon history?

Sounds to me like the remote isn't sending the back or home commands to your shield correctly.

I found it.

AuviPal G9 Backlit 2.4GHz Wireless Air Mouse Remote with QWERTY Keyboard

On Amazon

If there's a better remote that solves this problem I'm all ears.

the nvidia remote would solve that; maybe buy the nvidia replacement, since its the remote that is the issue

Also if you have the older remote you can upgrade to their newer one that is far better with a backlight. Not sure which shield you have.

I'm not so sure it's the remote, I'll keep investigating.

if you had the proper remote, you could use it to kill all programs, including channels dvr, then you wouldnt have to do a power plug pull..

If this isn't a proper remote, why has it worked fine for 2 years and was so highly thought of in the forum?

Maybe it has a low battery?

FWIW I've never heard of this remote and don't know of any other users using it. I searched the forum and didn't find any mention of it.

1 Like

I thought of that, so I've charged it every other day, for a week. It didn't matter.

I never heard of that remote either

If you want your device to work properly, you have to use the remote made for it, or, one that says, "works with Nvidia Shield"

You need glasses. Read the Amazon as. It specifically mentions the Shield. Now, I'm trying to get real answers and you are just being a jerk. Buzz off.

Latest Shield remote $30