Changing Channels Slow


#1

Hello,

When changing channels on my Shield TV/Fire TV, it takes 9-10 seconds to load the channel. I have the dvr service running on a shield tv (connected via Ethernet) with an external hard drive connected. This issue is happening on multiple shield and Fire Tv devices in our home. Any suggestions as to what can be done? Thank You.


#2

When you are watching a channel on a TV, what does it say in the Activity section of the DVR web UI?


#3

Is the activity section same as the log? Below what the log for when you change a channel. I changed the numbers to hide my IP. Let me know if you need any more info. I posted two examples from the log.

2018/07/28 19:09:55 [TNR] Opened connection to 1071A805 for ch4.1
2018/07/28 19:09:55 [HLS] Starting transcoder for channel 4.1 from 47.XXX.XXX.XXX (encoder=h264_mediacodecndk, resolution=720, deinterlacer=blend, bitrate=6000)
[hls @ 0x2024464c00] Timestamps are unset in a packet for stream 0. This is deprecated and will stop working in the future. Fix your code to set the timestamps properly

2018/07/28 19:12:30 [HLS] Stopping inactive session ch5.1-dANY-75b66e597db7 @ 58.284967s
2018/07/28 19:12:30 [TNR] Closed connection to 1071A805 for ch5.1
2018/07/28 19:12:44 [TNR] Opened connection to 1071A805 for ch5.1
2018/07/28 19:12:44 [HLS] Starting transcoder for channel 5.1 from 47.XXX.XXX.XXX (encoder=h264_mediacodecndk, resolution=720, deinterlacer=blend, bitrate=6000)
[hls @ 0x2dfa864c00] Timestamps are unset in a packet for stream 0. This is deprecated and will stop working in the future. Fix your code to set the timestamps properly


#4

Your clients are using transcoding, which is only required for remote access. It sounds like you used the “Login to remote DVR” option even though you are at home?

I would recommend logging out of the remote DVR and letting the apps find the DVR automatically. If thats not working, uncheck and recheck the Bonjour checkbox on the DVR.


#5

That was the issue.
One thing i noticed is that on channel 8.1 it pixelates when I am not transcoding. If i use the login to remote dvr option the pixelation goes away. If i can live with the 10 second delay is there any downside to leaving this on for all devices or if I can just transcode channel 8? I am using a HDHomeRun Quatro. Thanks


#6

On which device? Can you try with Surround Sound set to off on the Player tab

It’s better not to transcode since it makes things slower and also uses more resources on your Shield. But it’s up to you. You can change the Home Streaming Quality- no need to login to remote DVR.


#7

Shield TV. Surround Sound is off. It does it when changing scenes or bright objects.


#8

Does it happen in recordings too? If you can make a short recording where it happens and send it me I can try to fix it.


#9

It does show up on recording. I can send that to you. One more thing to note, when I wrote to HDHomeRun they mentioned that the bandwidth on channel 8.1 was split between four channels which is why it pixelated (only channel in dfw to this). So i was surprised to see transcoding could make a significant improvement. How would you like the video sent? I can also forward the reply HDHomeRun sent about that channel. Thanks.


#10

Email to [email protected]

Does the same pixelation happen on the HDHR app too?


#11

Yes on HDHR App it happens as well. I will get that email/video sent to you. Im guessing its just a hardware limitation with the tuner but it would be awesome if channels could find a solution for this. Thanks.


#12

One more thing is there an easy way to get access to that recording of the shield tv external hard drive or via the web?


#13

If you find the recording in the show list on web ui, right click the preview image to copy url, then change preview.jpg at the end to stream.mpg


#14

I have just sent the email. I’m not sure if the web player shoes the pixelation but on the shield tv itself it does show when playing back the video. Thanks


#15

Do you see the pixelation on the FireTV also, or SHIELD only?