Channel scan throws error on Pi4 Server

A Channels Plus DVR server running on a Pi4 was tested on a network with an HDHomerun tuner and it worked perfectly. Now its moved to a different network with a different HDHomerun where Scan Network from localhost:8089 on the Pi reports
TypeError: is not a function
in Settings.
Whats wrong?

Was the original dvr running a pre-release? Can you try updating the new DVR:

curl -XPUT

It’s on a current release, but it’s replacing a server that was running on a Mac, and that server was still online. I’m helping a friend I built that server for. He’s in the process of taking the Mac-based server down, rebooting the HDHR, rebooting the pi server and we’ll see what happens. If that resolves it, I’ll so flag this post. is there normally a problem with two servers trying to share an HDHR? not that its required in this setup.

Two servers can share a HDHR. This is a bug you're encountering, and one that we've probably fixed recently so it should work with the pre-release. You can also click-and-hold on the Check for Updates button to upgrade to it.

Cold reboots didn't resolve the problem. ‘Having trouble getting past that browser error. Using curl threw an error that it could not resolve host XPUT. The crashing server was installed the same way I installed my own which has been running for months. I just updated mine and it loaded 2020.03.24.0127. Does that have the bug fix? If not, how does one force upgrade to a pre-release and what version are we looking for?

Can you post the exact output of the curl command? Did you copy/paste it exactly as shown above?

Yes that's the latest version with the fix.

Will do that later this evening and advise.

Typo in the check/prerelease. When invoked correctly, it exited with true. After that, the server identified itself as 2020.03.24.0127 and everything worked perfectly.

Thanks for the help! You guys are the greatest.

1 Like