Channels DVR Disappears from tvOS


#1

Hello - Hoping for some help here. Been having a recurring issue for the past several months where occasionally the DVR features in my AppleTV Channels app will disappear, and won't come back unless I restart the device. The last time it did this was perhaps a month ago, and it stopped happening for a while but now has returned.

As best I can tell the DVR service is still running correctly - this has actually occurred while a show was recording, but the recording itself was not affected and the server is still running on the mini-PC I have it installed on upstairs. I can't tell if it's only the tvOS app that's having the problem but that seems to be the case, to me anyway. I also had the server log open for a while and checked after noticing the DVR options disappeared again, and there were no corresponding entries during that time. The bonjour service is checked and running; I only have the DVR server installed on one device, which is connected to the AppleTV via ethernet; there have been no network issues I'm aware of; HDHR Quarto firmware, tvOS and PC versions are all on the latest version. Not sure what else to check but I can't seem to figure this one out.

Any help would be hugely appreciated - Thank you!


#2

Can you check the Apple TV apps log, by looking up its IP and using http://x.x.x.x:57000/log while the app is active


#3

Yes, would you like me to paste here or send another way -


#4

You can email to [email protected]


#5

TvOS is reporting no network access at all:

The Internet connection appears to be offline.

Strange if it's hard wired..


#6

Is http://192.168.1.119:8089 the correct url for your DVR? Maybe the servers ip changed?


#7

The device under that IP is listed as my Plex server, though both it and Channels are running on the same PC. I also currently have a VPN running on the PC, could that be an issue? The AppleTV is connected via router which is connected to the modem; the PC is on the same network through the router.


#8

Are you able to open that url from a phone or other device on your network?

Is the Apple TV able to stream other stuff from the internet?

Try restarting the Channels app by clicking TV/Home on the Siri remote twice and swiping up.


#9

Yes; the url opens the Channels DVR settings deck

Yes, all other apps are working normally (tried YouTube, Netflix, etc.)

Restarting the app does not work, though restarting the AppleTV does


#10

Quite strange. We use the http client built into tvOS to connect to the DVR, and it's failing and saying there is no network connection. May be some sort of bug in tvOS.. I've never seen anything like this before.

You could try putting the ATV on WiFi for a while to see if the same thing happens.


#11

OK, I'll try a few things, see if it continues on Wifi. I also sent you another pasted log just now as it seemed to have some different errors from previous, not sure if related. Thank you for taking the time to look at this for me, I do appreciate it!


#12

Those messages are okay. Looks like it's connected to the DVR now.


#13

I had the same problem too. It seems anytime the router would restart for whatever reason, it would assign new IP addresses to every device. To fix this, I assigned a Static IP address to devices that needed to never change. Such as the HDHomerun, DVR computer, Ooma, ecobee, and printer. After making the router setting, you’ll need to restart the router and every device attached.


#14

Thanks, I can give that a try as well - my router hasn't restarted in about a month so I'm not sure that's the issue but it's worth a shot


#15

Just following up on this one in case anyone has any ideas. I've tried using WiFi and am having the same issue. IP address of each device involved is static. No dice.

One thing I noticed - and I don't know why this works, but I've tried it several times now and it seems to work reliably - is that once the DVR options have disappeared, if I go into Settings and click the "Rate Channels on the App Store" link, let the App Store load, and then switch back to the Channels app - the DVR options come back. If nothing else it's a little faster than having to restart the Apple TV, but still odd.

I've emailed a section from the app log that covers the most recent instance of the above, in case there's any relevant info there. Perhaps not, but figured it was worth a shot!