Channels DVR on ATV

I can’t see the DVR on the ATV. Do I need an updated version of the app?

Are you using the alpha?

No. how do I get it?

It will be available soon and will be called the DVR Beta. I expect within a couple weeks.

Invite has been resent

Ok got it but I am still not seeing the DVR. Do I have to do anything special for it to show up?

Did you install the DVR server and set it up with your tuner lineup and recordings location?


Try to quit and restart the Alpha app. Click TV/Home twice and swipe up.

What kind of system did you install the DVR into?

Already tried restarting app & ATV. I am using a iMac

I did it again & it started working

I have a similar issue on one of my ATVs… DVR is no longer in the Channels App. Was there before but somehow it disappeared. I removed the app and reinstalled it and still nothing. My other two ATV are OK.

I am still having issues seeing the DVR on my ATVs. I have 5 of them & seems like it sometimes works & sometimes doesn’t. Anyone else having this issue?

A new Testflight Beta was pushed out. For those of you that are part of the Beta testing team, could you try it and see if it has fixed this?

Seems to be better so far

I am still having issues on 1 of my 5 ATVs. Still can’t see the DVR & Recordings tab

Is there something funny or different about how it’s on your network compared to the other Apple TVs?

Nope its on wireless. I have 3 wired & 2 wireless ATVs. Not sure what to try. I have restarted app & restarted ATV.

Is it hitting an Access Point that is different than the access point that the other wireless Apple TVs are using?