Channels DVR Windows recordings lags when skipping


#1

I have just recently switched over from a Mac based Channels DVR server (running on a 2012 MacBook Pro, connected with ethernet) and have now switched over to a Windows based server running Channels DVR. Before, on the Mac side recordings would skip instantly and had no issue. However now on the Windows version recordings seem to lag. And here is the craziest part, the lag on the Apple TV only happens if it is connected via ethernet, it works fine via Wi-Fi.(Seems to be a ethernet speed limitation, as it worked fine on our ATV 4K, which has a gigabit port, and every other ATV is a 4th gen.) All ATV's were hardwired with the Mac version and now they do function the same as with a Windows install. I would prefer Ethernet over WiFi as it is more stable, however I am confused on how this might be an issue.


#2

So it only happens on the ATV4 and only on Ethernet? ATV4K with gigabit is fine.

Do you have flow control disabled on the windows Ethernet driver? The dvr usually prompts you to disable it during the dvr install.


#3

Correct, the installer did not prompt me to turn off flow control, the DVR software is running in a Windows VM. There is no option for flow control in the network properties of the adapter. The server has a 10 gigabit link to the physical network.


#4

Is flow control enabled at the host level? I would think it could cause issues there as well.


#5

Several others including myself have reported this problem but it hasn't gotten fixed. I stopped getting responses in the below thread while trying to help troubleshoot it for them. There is definitely something in the Windows version of this software causing the issue. I'm currently running a separate old Ubuntu box just for Channels because of this issue.

https://community.getchannels.com/t/slow-dvr-performance-on-4th-gen-apple-tv/9330/19


#6

If you right click on the system tray it should show a flow control fix option. It might already be disabled- if it's not the dvr web UI would show a warning about it.

It might be worth enabling flow control to see if that fixes this issue. If it's really only happening on 100mbps connections that's helpful information we didn't have before.

See Windows DVR BUG: Glitches during recording


#7

I do not have an option to disable or enable flow control. The option does not seem to exist in my VM. And yes, I have now tested on 3 different ATV 4th gens, it is only happening on 100 mbps connections.


#8

So there's no flow control entry at all in the Ethernet driver?


#9

image Correct, this is all that it shows


#10

Okay thanks.

There is some weird interaction happening with the dvr software and the windows networking stack, but we haven't been able to figure out what exactly yet.

If you'd like to try the latest dvr pre-release you can hold the shift key and click Check for Updates. There are changes in there that might help.


#11

Okay let me try that, I'll let you know if it fixes it. Gotta wait till the house goes to sleep so I don't disrupt any recordings


#12

You can shift click and it will wait to update until everything is idle.


#13

Ah gotcha, will do


#14

Just tested, it feels maybe ever so slightly faster, but could just be a placebo effect. It is generally fast after the first skip, but anything after that or skimming through the recording takes a bit for it to load.


#15

Not sure if you've tried this, but you could disable Windows network autotune.

Go to an admin command prompt and type:

netsh int tcp set global autotuninglevel=disabled

You'll probably need to reboot the computer.

If you find it doesn't help, you should probably re-enable autotune. To re-enable Windows network autotune use:

netsh int tcp set global autotuninglevel=normal

I've not used this for Channels as I use it on a Macbook Pro. But I have had to disable Windows network autotune for other server based apps where it was affecting the throughput.


Slow DVR Performance on 4th Gen Apple TV
#16

That actually fixed it! We should mark this as the solution for anyone else having this problem or put it on the FAQ


#17

Wow, thanks for that @AndreVaux

Looks like there are several other options for the autotuning option, so it might be worth trying some of the others to see if they also fix the problem.

autotuninglevel - One of the following values:
disabled: Fix the receive window at its default value.
highlyrestricted: Allow the receive window to grow beyond its default value, but do so very conservatively.
restricted: Allow the receive window to grow beyond its default value, but limit such growth in some scenarios.
normal: Allow the receive window to grow to accommodate almost all scenarios.
experimental: Allow the receive window to grow to accommodate extreme scenarios.

#18

Reading more about autotuning, it doesn't seem like its a good idea to turn it off. It will negatively affect other internet based downloads. However, if it really does make a difference that gives me an idea of something I can change in the app that might fix the problem.

@Marino13 @Bob_Prendergast @nonebeter99 Can you try disabling autotuning to see if it fixes the problem for you as well? Let me know, and if it does I will send out a beta build with some changes and you can try that with autotuning set back to normal.


#19

Well, I wasn’t complaining because my ATV4k was fast, but my ATV had a 3-sec skip that I wasn’t complaining about (cause I was still saving 27secs), but this made it fly like the 4K was.

Thanks @AndreVaux for pointing this out!


#20

I've put out a new beta build (available via getchannels.com/beta) which should fix the seeking problem even with autotuning enabled. Let me know how it works.