Channels problems with no internet slow “Loading...”

My internet is out and I’m trying to watch some channels recordings or live TV but the app didn’t want to start at all. I killed it and restarted but it just says “Loading...”
I ended up doing something else and came back and it finally loaded. BUT there are some issues. You can’t tell what any of the recordings are because none of the art is shown and all of the boxes show up empty. If I hover over the boxes I can sort of use it. But Up Next is useless because it just says “Season 3, Episode 1” underneath. No idea what show. Recently recorded is better because you can at least see the show name when you hover. But when I go into the show, again there are no images for the recordings.
I think Channels should work perfectly without internet, since it records over the air. And if the internet is out, it is the go to app since you can’t watch Netflix or Hulu etc.
I suggest the following:

  1. Update the DVR functionality to archive recording art on the DVR so the internet is not required for screenshots etc.
  2. Improve loading time by loading whatever is being loaded on launch asynchronously in the background.

I just timed it and it took roughly 1m54s to load channels on the ATV. And about the same on iOS.
Here’s a screenshot of how it look on iOS (similar to the ATV):

Strange it would take that long as it shouldn't be trying to connect to the internet during load. Can you pull the logs from the ATV after it finishes loading and send them to us. You can use the ATV IP to access http://x.x.x.x:57000/log

I can't reproduce it now that the internet is back. The internet connection is fiber and the DNS was out in some weird way where I think requests went out and never were returned. So everything had to time out.

BUT Now I have a new problem where the guide just shows up as the channel name, no guide data, no logos. Tried "Fetch Guide Updates" no change. Tried "Re-Download Entire Guide" no change. Tried "Refresh Station Logos." no change. Tried killing and re-starting channels after each one. Submitted logs through the app.

What should I try next?

What does the dvr Log show?

I didn't see anything too interesting. Just sent them to support email.

Any ideas? The guide is still showing empty.

Restart the app? Does it show the correct dvr IP on the DVR tab?

Restarted the app. Fixed it for philo channels only. Then downloaded guide data and it fixed it!
Wonder what caused it.