Choppy Playback on shield


#1

I've been getting choppy live TV playback on shield. Thought it was antenna. Went on iOS and tried with iPad and iPhone...zero issues. Back to shield and choppy. What gives?


#2

Does it happen in the official HDHR app?


#3

I'll try that tonight. Side note I don't think it's a channels issue just wondering if anyone else has similar issue. May get an apple TV and see if there's a difference.


#4

Usually it means the WiFi connection at the shield is not good. But comparing with another app on the same SHIELD will tell you for sure.


#5

I am experiencing the same issue. Choppy play back on live TV and slow channel changes (5 to 15 seconds) - often just a complete fail on change channels forcing me to go back to the guide and reselect the channel I want. Started happening when I installed a new HD Homerrun HDHR5-4US (The US Quatro) into my system. Thought it was the new hardware so I unisntalled it and went back to my old HDHR-2US (Homerun Connect 2 channel). However the problem is still there making live TV watching a very poor experience. FYI. Silicondust's native HDHomerun App works fine no stutter and quick (1 to 3 seconds) channel changes on the same NVidia Shield TV. Is there any solution? Suggestions?


#6

Can you submit diagnostics after the issue, on the bottom of the Player settings tab.


#7

Will do when I get home this evening.


#8

BTW - Thanks for the amazingly quick response!


#9

Also if it is any help I noticed very similar behavior (Choppy Playback etc) with the Android TV built in Google 'Channels' app before I disabled it.


#10

Could be an audio issue. Try setting the Surround Sound setting to Off on the Player tab as well.


#11

Here are some snippets from the ChannelsDVR Server Logs:

2019/02/13 09:34:55 [TNR] Opened connection to 10473FFC for ch4.1
2019/02/13 09:34:55 [HLS] Starting transcoder for channel 4.1 from 10.20.30.15 (encoder=h264_mediacodecndk, resolution=1080, deinterlacer=blend, bitrate=8000)
[hls @ 0x2430865c00] Timestamps are unset in a packet for stream 0. This is deprecated and will stop working in the future. Fix your code to set the timestamps properly
2019/02/13 09:35:08 [ERR] Failed to start stream for ch5.1: got HDHR error: 805 All Tuners In Use
2019/02/13 09:35:18 [HLS] Stopping transcoder session ch4.1-dANY-ip10.20.30.15 @ 22.2126s
2019/02/13 09:35:18 [TNR] Closed connection to 10473FFC for ch4.1

2019/02/13 08:08:58 [HLS] Starting transcoder for channel 4.1 from 10.20.30.15 (encoder=h264_mediacodecndk, resolution=1080, deinterlacer=blend, bitrate=8000)
[hls @ 0x26a9465c00] Timestamps are unset in a packet for stream 0. This is deprecated and will stop working in the future. Fix your code to set the timestamps properly
2019/02/13 08:09:11 [TNR] Opened connection to 107355B9 for ch7.1
2019/02/13 08:09:11 [HLS] Starting transcoder for channel 7.1 from 10.20.30.15 (encoder=h264_mediacodecndk, resolution=1080, deinterlacer=blend, bitrate=8000)
[hls @ 0x2acec65c00] Timestamps are unset in a packet for stream 0. This is deprecated and will stop working in the future. Fix your code to set the timestamps properly
2019/02/13 08:09:35 [WRN] Buffer for 107355B9 ch4.1 is more than 50% full (clients=1, len=16779000)
2019/02/13 08:09:39 [WRN] Buffer for 107355B9 ch4.1 is more than 50% full (clients=1, len=16779132)
2019/02/13 08:09:41 [HLS] Stopping transcoder session ch7.1-dANY-ip10.20.30.15 @ 25.141778s
2019/02/13 08:09:41 [TNR] Closed connection to 107355B9 for ch7.1
2019/02/13 08:09:41 [HLS] Stopping inactive session ch2.1-dANY-ip10.20.30.15 @ 45.378666s
2019/02/13 08:09:41 [TNR] Closed connection to 107355B9 for ch2.1


#12

It looks like you've set your Home Streaming Quality to 1080p. It should be set to Original for best results, to avoid the transcoder on the DVR and just stream directly from the HDHR.


#13

Got it - thanks I will try that when I get home. Your support is really impressive - I much prefer to pay for an app/service which is decent than an unreliable free/ad supported app - keep up the good work. Apart from this one issue I have been thoroughly impressed by ChannelsDVR so far.


#14

Yes this was the problem and your fix worked. I must have accidentally changed the setting. Changing it back to 'Original' stopped the stuttering choppy playback and the channel changing issue. Thanks again.


#15

well I love android but my little test proves apple out on top. My shield has been dropping video, and just terrible with live tv. Got apple tv (after trying channels on my wifes ipad without any issue) ZERO issues with tuning.