Client>NVidia Shield Pro> "DVR Not Found" Problem When Powering Down TV


  • Running client on NVidia Shield Pro, displaying "Library"
  • Turn off the Yamaha which cuts power to TV (root cause of problem)
  • "DVR not found" quickly displays on the TV, then screen goes blank
  • Powering on Yamaha powers on the TV
  • "DVR not found" displays.
  • Pressing 'Back' button returns to "Library" screen

Troubleshooting: why is cutting power to the TV causing this problem?


  • Server: PI 4 8GB w/1TB HDD (18% used) - Ver: 2021.0428.1701
  • Sources: HDHomeRun Prime 3 & TVE via Direct TV
  • Client: NVidia Shield Pro - Ver: 3.5.0
  • Network: all 3 devices directly connected to same ethernet switch
  • AVR: Yamaha V685 connected to 'master control on power strip
  • TV: Samsung Q9FN connected to 'switched' on power strip
  • Power: Yamaha master control on power strip cuts power to TV
    All other devices inc. ethernet switch always powered on

NVidia Shield Pro Settings Details:

  • Screen Saver>Put Device to Sleep> Never
  • Display & Sound>Power Control> all CEC options disabled
  • Display & Sound>Volume Control> CEC disabled
  • note: Yamaha & Samsung CEC disabled as well

What happens if you physically push the power off button on the Yamaha with your finger? What remote are you using to turn off the Yamaha? Is the shield hdmi plugged directly into the tv and using arc for sound or shield to yamaha to tv? Is hdmi pass through enabled or disabled on the Yamaha? Is there a reason you are using this power switch setup over cec(tv hum in standby or something)?

Super Thanks!!! I will work thru all your suggestions in the AM....

Sure, I was thinking it might be an hdmi handshake issue or possibly something weird with your remote sending the power off but also confusing the shield or possibly if you are using something like a Logitech remote sending a power off to the shield at the same time as the power off to the Yamaha

Rice, you nailed the root cause: Logitech Harmony Hub Remote!!

The NVidia is routed thru the Yamaha (HDMI 5) to the Samsung (HDMI 4). A TiVo is also routed thru the Yamaha (HDMI 1).

When I use the Harmony to switch from NVidia to TiVo, "DVR Not Available" shows up on the screen and then it switches to the TiVo.

Using the Yamaha remote to switch from HDMI 5 to HDMI 1 does NOT cause "DVR Not Available" to show up :frowning: Nor does using the Samsung remote to stay on HDMI 4 cause the issue..

And I visually confirmed that switching from the Nvidia activity to the TiVo activity did NOT power on / off the NVidia device.

Powering NVidia on/off, powering Samsung on/off and powering Yamaha on/off by themselves did not caused the issue.

I also used the Harmony app on my phone to send various remote commands from NVidia, Yamaha & Samsung and nothing caused the issue.

Harmony Setup:

  • Device>Samsung>Power Settings>No power buttons on original remote
  • Device>NVidia>Power Settings>No power buttons on original remote
  • NVidia Activity>Startup> Yamaha Power On, Yamaha HDMI 5, Samsung HDMI 4
  • NVidia Activity>Shutdown> Yamaha Power Off, Samsung, NVidia Power Off (manual)
  • TiVo Activity>Startup> Yamaha Power On, Yamaha HDMI 1, Samsung HDMI 4
  • TiVo Activity>Shutdown> Yamaha Power Off, Samsung, NVidia Power Off (manual)

So any suggestions here would be deeply appreciated :slight_smile:

Being in the NVidia Activity and then hitting "Off" on the Harmony causes "DVR Not Available" to show for a brief second, before Yamaha turns off.

If the NVidia has gone into screensaver mode, then "DVR Not Available" does NOT happen with the Channels Client app. You must switch-activity/turn-off while the Client app is displaying on the screen.

Lastly, the Yamaha is set to disable video processing aka HDMI passthru.

And I am using the master control power strip to save on electricity - the Samsung One Connect Box uses a lot of electricity, even when 'off', so now turn it 'off' by cutting the power to it via the power strip.

I too have a Yamaha, shield, and harmony hub. Mine does not do this. I believe the deference is the shield power down sequence. I think you need to remove the shield power off(manual) part from all shutdown activities . So the shield is always on. I cannot verify my hub settings at the moment. Also is you TiVo power down sequence a typo, it shows nvidia power down(manual)? I think this might be as simple as powering the shield down drops the network connection to the server before the channels app is suspended causing this glitch

I have my Nvidia>device>power settings set to "no commands for this device". Which is why in the mobile Harmony app the word "manual" is next to the power commands in setup/shutdown.

I created a activity without the NVidia and it works perfectly without having any Nvidia remote buttons.

I then changed the NVidia>Device>Power Settings to "leave my device always on". I then changed the power off/on commands to NVidia>Stop. And back came "DVR Not Availabile".

Is your hub connected to your shield via bluetooth or IR? Mine is via bluetooth. That might be the cause.....

Ok got a chance to look at my hub settings. Mine might be a little different because I have added a windows pc to my shield activity. There is no pc really but this is a work around to get full keyboard commands sent Bluetooth to the shield with the hub. Like “p” for the pip along with any other letter or F1-F…. Any way I’m using Bluetooth not IR.
Nvidia power settings
“Keep device always on” next arrow is “use two buttons” next arrow “power on> home” power off sleep.
Start sequence
Tv power on/Yamaha power on/ shield power on windows pc power on
End sequence same as above with all power off
Windows pc set up with no power buttons on remote
I will say that my shield does not sleep nor power off at any time
Under channels app general, start up start up section I have default and set section on app launch and resume. What are your settings herein the app? If these don’t work I think you should try plugging your tv from the master switch into a non switched outlet to rule out a hdmi handshake issue

We can rule out HDMI handshake issues - issue comes up just switching from shield to TiVo and back to shield aka just changing Yamaha HDMIs. Again, have to be on the 'Library' screen for issue to occur.

Your suggestion about using "Home" as part of the powering sequence WORKS!!!! I choose "turn off this device when not in use" and set both startup & shutdown to "Home". No more "DVR Not Available" :slight_smile: :slight_smile: :slight_smile: because of course we are not longer sitting on the 'Library' screen.

S U P E R _ S P E C I A L _ T H A N K S _ F O R _ Y O U R _ H E L P

Sorry to bring back this old thread but I don't feel that making a new one is necessary. This isn't channels related but would love to figure it out.

Since day one of using a Polk soundbar with a Samsung TV connected over ARC, it will stop working after a short time, and measures need to be taken to make the soundbar work again.

So it goes like this. If I kill the power to everything, and cut it back on it will restore the HDMI handshake needed to properly power on and play through the soundbar. After some time the handshake breaks. It will always power the soundbar on, but to get it playing sound through it again I have to go into the tv settings, toggle Anynet+ off, then on, and it will begin playing properly. This will have to be done everytime I power the tv on. The handshake is broken now. To restore it I have to power cycle everything again. I've tried 3 different cords. Some will work longer than others, but never longer than a few days. I know I'm stupid and all, but I kinda think I've tried everything at this point to try and have a rock solid ARC connection but I'm convinced it's impossible.

Unfortunately I think you are right. Samsung and Polk have a history of arc not playing well together. They each blame the other. My only suggestions are to check for a firmware update on the Samsung or to use optical input on the Polk.

1 Like

I've managed to find a suitable workaround for me by installing a smart plug on the Samsung tv, and called it Bullshit in Google Home. When the handshake breaks I just say 'hey Google turn off the bullshit." Then, "hey Google turn on the bullshit" and it restablishes the handshake.

1 Like