Client sits at blank purple screen for 10 seconds on launch

I'm on Beta 8.6.230 on a 2019 ShieldTV Pro. When I launch Channels for the first time, after a reboot or "dismissing" the app, I sit at a blank purple screen for about 10 seconds. I then get the spinner for about 1 second and then the UI loads. I've seen this in the Alpha as well, which is why I dropped back to the Beta. Once Channels has launched, I can switch back to it with no delay. It is consistently reproducible.

I'm not sure at what point the logging is enabled in the app. I can't access it by IP:5700/log?show=all until the UI comes up, and I only see 2 seconds of logs so I'm guessing logging isn't running when the problem is happening. Don't know if it's related, but I see these two lines in the log on the client:

08-06 15:39:13.372 27392 27412 E Fabric :$HttpRequestException: Failed to connect to

08-06 15:39:44.038 27392 27459 V ApiServer: REQUEST: GET /log
08-06 15:39:44.068 27392 27459 E fi.iki.elonen.NanoHTTPD: Could not send response to the client
08-06 15:39:44.068 27392 27459 E fi.iki.elonen.NanoHTTPD: Broken pipe

Update: I did a force stop and clear data on the app. When I launched it, I still got the blank screen for about 10 seconds before the "Welcome to Channels DVR" screen appeared.

Very strange. Do you have a computer you can run adbLink logcat to get all the system logs from when the app is starting?

Yeah. I have a Win10 laptop. I haven't used adb before, but if you tell me what to do I can do it. :grinning:

I think you can use this one

Just emailed [email protected] the logcat file. Subject is the title of this thread. It looks like the issue might be between 18:21:33.904 and 18:21:47.759?

Could be a bonjour delay in dns resolution. Can you click Connect to DVR > At Home and enter IP of your DVR.

Just tried that and it made no difference (I've always used the IP for connecting from the client). I did have bonjour discovery disabled in the Channels admin website, but turning it back on didn't make any difference either. I had it disabled because I thought it was an Apple only thing until I read more about it. Anyway, as I mentioned enabling it made no difference.

Any update on this, or any other info I can provide?

It's still not clear what's going on. Are you using pihole or something else that's blocking crashlytics. Would be useful to know if the same thing happens without that enabled.

I actually am using Pi-hole. I disabled it and tried again, but still have the issue. I also tried setting the DNS servers my ShieldTV uses to and No luck with that either.

Tried this on my 2017 Shield TV hooked up to a different TV and had the same problem, so it's not device specific.

1 Like

What about if its disconnected from wifi and has no network?

If I disconnect / turn off both wired and wireless, the Connect to DVR screen pops up immediately when I launch Channels.
I also checked the Tivo 4k Stream I bought to play around with, and I get the blank purple screen even longer on it than I do on the Shield TV. I'm assuming it's because the processor is slower (tried both wired and wireless).

Can you upgrade to 8.20.1826 beta then reproduce and submit diagnostics

Done. It was actually on 8.20.2145 when I did submitted them.

Thanks! I see the 15s gap in the logs. I've added more logging based on where it stopped in v8.21.2039, and would appreciate new diagnostics when you get a chance.


Any update on this, or any other info I can provide?

Another adb log with the latest beta would be helpful

Just emailed [email protected] the logcat file. Subject is the title of this thread. Client version was 8.27.438. I also submitted new diagnostics as well. Thanks.