Comskip works but not used

With Channels on a new system, I turned Comskip on, since I now have CPU power to use on it. I used Chrome and picked an episode of a show to check if it worked. (If it helps, it was The Andy Griffith Show, in black and white.) On the web viewer I could see the indications where the commercials were skipped, but in playback, it went right on and played through the commercials anyway, just as normal.

I tried the same episode, plus episodes of other shows (including Three's Company, in color), both from Chrome and on Apple TV. On Apple TV I tried this on the release version and beta version of Channels. Both of them have Comskip on so they should be skipping the ads.

Also, as a side note, I ran into an odd situation on the beta on Apple TV. I tried the episode of Andy Griffith that I mentioned, where the web viewer wasn't skipping the commercials. When I clicked on Watch, it acted like it started to play the episode, then a black screen, then back to the screen with the episode details and controls came back. It happened repeatedly. I did this for every episode that had been recorded on the new install of Channels.

Then I went back and started playing an episode that had been recorded on the older instance of Channels, without comskip. That started fine. Once that was done, I went back to trying to play the new episodes and there was no problem.

Things seem to be working, but I thought I should report this. I don't know if it's related to the comskip issues or now.

The web player does not skip commercials.

The Apple TV app has settings to let you manually or automatically skip commercials during playback.

If the player is exiting without playing, it probably means the DVR wasn't able to access the video mpg file either due to incorrect DVR path supplied, or permissions issues on the files.

I have both the beta and release version on the Apple TV set to automatically skip commercials, but neither one is doing it.

With the videos not playing - Most likely not the permissions. Read permission is set for user, group, and all. The difference between the new recordings, made on the newer Linux DVR, is that they do not have the user 'x' flag set. But there's more to it than that.

(In this case, "new" refers to either the new Linux install of Channels or a new video recorded by Channels on the Linux computer. "Old" refers to the previous install of Channels on my MacMini or files recorded on the MacMini and then copied over to the Linux instance of Channels.)

At this point, I'm tempted to classify this in the nightmarish "intermittent problem" category.

Note that before I did this, I had turned Bonjour off for the old install on the MacMini and used the auth/refresh link you gave me. I saw the new Linux system listed on my account and the old one was gone.

  1. I tried playing one of the new files in Chrome and it played.
  2. I tried a few other new files in the Chrome player and they played okay.
  3. Since comskip wasn't working on the web player (which I now know is normal), I tried it in the beta on Apple TV. I played a new file and it wouldn't play. I tried multiple new files and none would play. I tried an old file and it played.
  4. Since the old file played, I went back and tried some new files. They played. No commercial skipping.
  5. I went back and forth between the beta and release version, trying new files. The new files played without a problem. Even though comskip was on automatic for both viewers, it didn't work in either one.

NOTE: At this point, the new files were playing. I had not altered them, but they were now playing, but comskip wasn't working. I want to be clear that, by this point, new files WERE playing.

  1. I posted about this, then watched an old file on the beta. (Old file but it's on the new machine.) It was a 30 minute episode of Adam 12. It finishes and won't play the next episode. So I go to another new file and try it. It won't play. The old Adam 12 file that didn't play before won't play. Even the old Adam 12 file that I had already watched would no longer play.
  2. I read your response, so I looked over the directories, using "ls -l" and found the new files and old files only had one difference in permissions: The new files did not have the 'x' flag on for the user. All had the 'r' flag on for user, group, and all, and the 'w' flag on for the user. Old files had the 'x' for user set. (So old files had rwxr--r-- and new files had rw-r--r--.)
  3. I used chmod to change all the video files (but not the directories or any other files) to rwxr--r--. I went into the beta version on Apple TV to play them. They wouldn't play. No files would play.
  4. I am frustrated and want to think, so I take a break to drive to the 7/11 and grave some greasy food. I get back, about 15-20 minutes later, and try to play something in Channels. Nothing plays. Both have on the screen:

"Welcome to Channels DVR Your DVR is not quite set up yet. Visit this URL in your browser to complete it." And, of course, it has the IP address of my Linux system with the new install and the 8089 port. I go back to that page in Chrome. It comes up okay, no problems. I can't see what I need to change that's become undone.

I doubt this is a permissions problem, since changing permissions didn't matter. I do wonder if some of this intermittent failure and things taking time to show up or go away might have to do with propagation issues and whether the Apple TV viewers were going to the old machine for a while, then had problems with the new one.

Long story short, it's working now.

I was running into more and more trouble, to the point where all I could get on Apple TV was the intro screen telling me to finish setting up the DVR. I tried watching videos in Chrome and from an iPhone, with Channels. They worked.

It turns out that I had planned everything out with the changes to my LAN to put the new server running Channels at one location, but the old server is still there. I was stuck thinking about what I'm planning to do, so I got the IP address wrong.

So with Chrome, I was using the machine name and not an IP address. With the iPhone, it picked up on the new install (since that's running Bonjour and the old install isn't). But the Apple TV apps were still going to the old address and, for a while, I had disabled that DVR. They weren't even giving me the option to change to a new IP address for the Channels server.

I removed the apps, restarted Apple TV, and installed fresh versions of the beta and release versions and now it all works, including comskip. I had figured that after I turned off Bonjour on the old server and turned it on for the new one, that the apps would discover that and changeover. They did not, so when they weren't skipping commercials, it was because they were playing files from the old server.

So put it all on me not getting that the Apple TV apps were not listening when the new install was using Bonjour and the old one wasn't.

I was really wondering what was going on because most things with Channels work seamlessly and elegantly, so this just did not seem like something I'd see go wrong on Channels.