Connect through Wireguard VPN

I run Channels DVR on my Unraid server. I frequently connect to the server through Wireguard VPN. I have the Channels DVR iOS App on both my iPad and iPhone. I have run into a weird situation.

If I am away from home and connect through Wireguard on my iPad, the Channels DVR App works fine. It finds the server, shows me a guide, I can select any show and watch.

If I do the exact same thing and connect through Wireguard on my iPhone, the Channels DVR app on my iPhone says "Your Channels DVR Server could not be discovered." I try to connect to it manually. I enter the correct IP address and it still says it cannot find the server. However, if I then go to a browser on my iPhone and put in :8089, I can access the Channels DVR web page and watch a show through that. So I know there are no networking or routing issues. As far as I can tell, I am using the same version of Channels DVR ios app on both iPad and iPhone.

Can anyone throw out some ideas as to why this might be happening?

There should be no difference between iPad and iPhone. Can you submit diagnostics so we can check the logs?

Please download the latest iOS beta from https://getchannels.com/beta/ and let me know if that fixes the issue for you.

We were restricting being able to connect to manually selected DVR addresses when on cellular to speed up remote discovery, but didn't realize it would still mark VPN connections as cellular.

1 Like

Eric,

That totally did the trick. Thanks so much. You guys are building a great product! I’ve been using for about a month but love it so far.

1 Like

Thanks for letting me know!

I am having the same issue, but the above solution did not work. I tried the beta version but it instantly refuses once I place the server's IP in. I can connect over HTTP on port 8089 in Safari and it works fine. Is anything else required but port 8089 TCP?

What version number is shown in the app?