Could not connect to [hostname]

What does this mean and how do I fix it?

"Could not connect to [hostname] Check if the port is mapped."

What kind of device are you running the DVR server on? There is a known issue affecting older Macs. If that could be the issue see the thread on that topic.

I installed the Channels Plus .exe on a Windows 10 machine. I am unsure where the Server is or if it is even on this machine. Anyway, when I open the Channels DVR App on that machine it opens a Browser page (MS Edge) and I get the subject message when I click on “Help” and it goes through an automatic “Troubleshooting” routine.

TBH, I am having a difficult time understanding exactly how Channels DVR is supposed to work. (FWIW, I have been using SageTV for over ten years (15?) and also use several other streaming programs regularly, if not daily – TABLO, EMBY, ATT TV NOW (Osprey device), Air TV. Fire Cube, etc. and also with ROKU Ultra and Shield devises so this should be a piece of cake for me. But somewhere I fell off the tracks and can’t seem to get back on.)

Have you tried using the DVR in your home yet? The connect error you posted only applies to remote access.

On your FireTV search for Channels DVR and install the app. It should connect to your DVR server on your Window PC automatically. If not, then there's probably a firewall blocking access on your PC.

Yes, I have recorded a little (as a test several months ago) with the DVR. Both Shield and Cube show connected to LAN, the address of the Windows 10 machine.

Actually, what led me down this path was in trying to figure out how to configure TVAnywhere and got sidetracked. (Still am lost with TVA)

What are you trying to configure?

It looks like you're already using some TVE providers? On the Settings tab there's a list of sources along with an "Add Source" button.

One thing that you may be running into is the IP address of your server machine might be changing, which is typically how things work by default. For best results you’ll want to set your server up with a static IP address.

Oh, I believe I am beginning to understand now. Yes, I have the 10 Tuners, AT&T TV NOW, and Sling TV listed as TVE providers. However, I have a couple issues with that.

First, is that, at least, one/two channels are not listed in the "Guide." -- that being FS1 & FS2, which both Providers carry. (There may be others.) Why is that?

Secondly, I dropped my Sling subscription for VIDGO when Sling made the sports channels an add-on. VIDGO is not found among the offered Providers... neither are Disney+ or CBS All Access which I also subscribe to.

Other than that, this "second look" has tweaked my interest and I will give it another chance.

If you log onto the fox sports go website are you able to log in with your AT&T or sling credentials and watch FS1 and FS2? If so, you might want to try going into the DVR web interface, click the TVE source edit button, and rescan those individual channels to see if they will successfully authorize.

If you have providers that are not listed as a TVE provider, they probably don’t use TVE, so Channels won’t be able to integrate their content.

Just to make sure I got it right let me say that I engaged the Channels DVR App, which opened in the Browser ( I, then, went to "_ Sources found" and clicked on the Edit Icon in ATT TV NOW and Sling. I then Clicked "Refresh." No joy.

FWIW, I can access FS1 and FS2 in several different ways without issue.

So, I suspect that Fox Sports has the same provider agreement issue with TVE as VIDGO seems to.

After clicking the pencil next to the TVE source, click “Edit”, then scroll down the list of channels until you find FS1 & FS2. Click the button to rescan each channel and see what happens.

The only access that matters for TVE is through a web browser. If you can access the channel through the channel’s own website using your provider credentials, it will likely work with Channels.

Oh! That worked. This is pretty complicated... however, it is logical and I am catching up rather quickly. Thank you.

1 Like

Yeah one of the easiest ways to think about it is that Channels is “pretending” to be you. It’s using a browser in the background to go straight to each channel’s website, log in with your credentials, and access the content available. Sometimes providers have streaming limits or other issues that can cause the connection to fail. Often, going in and re-scanning individual channels can resolve those issues.

Just when I think I have it under control, I get a comeuppance. In the Shield device, I have access to FS1 and it shows up in the EPG. However, FS1 is nowhere to be found on the Fire TV Cube. The only difference I see (of course, I don't know where to look) is in the "About" screen the Shield shows "Channels DVR (103122)" and in the Fire TV it shows "Channels DVR 2.1.20." How do I "refresh" the Fire TV App?

Then, after going back, I find another anomaly. The ATT TV NOW Tuner shows 100 Channels Found in the Shield App and 101 channels in the Fire TV Cube App... exactly the opposite of what is expected. What am I doing wrong?

Force stop and clear the cache of the FireTV app, then relaunch it. Also, it has the latest version.