Could Not Write Metadata error

Submitted diagnostics from Apple TV. Got this error trying to play last night's Catfish on test flight. It plays just fine from release version. I wonder if this is related to my 30 min commercial issue?

Could not write metadata for: /var/mobile/Containers/Data/ Application/181AB0C8-4BCD-48AE-8D83-DOAF7A6434EE/ Library/Caches/com.getchannels.Assets/channels-dvr-hls/
63646da197b07: cannot write data to tempfile "var/mobile/ Containers/Data/Application/181AB0C8-4BCD-48AE-8D83-DOAF7A6434EE/Library/Caches/com.getchannels.Assets/ channels-dvr-hls/STREAMS/ 6c444821cd4c16366f685bade78c1c6fbd3a482ba44b9a2c14e
63646da197b07/METADATA184694279": write /var/mobile/ Containers/Data/Application/181AB0C8-4BCD-48AE-8D83-DOAF7A6434EE/Library/Caches/com.getchannels.Assets/ channels-dvr-his/STREAMS}

This means the disk space on your iOS device is running low

On my AppleTV? Never had this issue before, and it plays just fine in the release Channels app. I have the 2021 4k w 32GB. Guess I need to delete some apps? Or is there a cache I can clean out?

Yes try clearing out cache under Settings > Support in both apps

Now I'm getting "The Channels DVR Server had a problem. Press play to try again." Pressing play does nothing. Backing out at pressing Watch again gives me the original error. No messages in the DVR log (2023.03.08.2138)

Something funky is going on. What if you delete the TestFlight app and reinstall?

Nope. First 2 attempts I got a black screen for a second or two then it backed out. Checked to make sure its on Default Video and Experimental Audio, tried playing again and it gave same error. Diagnostics sent again.

I decided to try rebooting the AppleTV and it's playing now. I guess "did you reboot" should've applied here. Thanks for the quick responses.