Delay in playback restart after seeking (Stalls)

Ok, since I travel 6 months of the year, I will probably just keep SageTV in the home doing recordings as its been truly bulletproof for the last 20 years and has oodles of features we use constantly. Then just use Channels in the Motorhome where I really need it's newer client capabilities so I can transcode the heck out of my TVshows prior to shipping them to the motorhome. Playing h.265 recordings etc. Now to figure out the multi press skipping sluggishness after about 3-4 skips on both my gigabit wired Shield TV clients. Often need to skip 10 times to get past commercials.
I will also look at using comskip in Channels to see if that might be a solution to the skip lag, I stopped using comskip many years ago as it would often just not quite get it right and the Wife would start complaining... I will start looking for a channels write up on how comskip works with it. -Bill

Do you have Streaming Quality for Home set to Original?

The top reasons that people generally run into with this sort of thing are:

  • WiFi/Network Issues
  • A Streaming Quality other than Original (so Transcoding is happening)
  • Hardware Decoder issues on various Android devices
1 Like

Hey, Bill, nice to see you over here after 2 decades in the SageTV forum.

I have been happy with (2) features of the Channels DVR software that I couldn't get working very well in Sage:

  1. Remote connections. My Firesticks work extremely well remotely when I'm traveling thanks to Eric's extensive work on transcoding.
  2. TVEverywhere. It's nice to have all those networks aggregated into one system. Yeah, TVE is dying a slow death and we are losing channels daily, but it still works okay for what it is.

Definitely check out Comskip, it works just as well or maybe a bit better than what you remember from Sage, and you can set it as an option on the client so when a commercial shows up you can choose to skip it or just let it run.

I get some sluggish activity when fast-forwarding remotely (understandably), but never on my local network - it's always quick and smooth with the Firesticks anyway.

Kind regards


No network issues 995 Mbps, 1.02 lat, 1.15 jitter, no WiFi for connected TV's, But my Tablet test shows 300+ Mbps for Channels app, your apps speed-test shown below.
Its still set to Original
How do I tell if its decoder issues on my recent model Nvidia Shield?
Is there a recommended hardware device?


There is a setting on the client to switch between the hardware and software video decoder. Changing that setting and seeing if it still happens would be a good start.

Also, if you submit diagnostics from the client right after you experience these sorts of stalls, it could shed some light on things.

1 Like

Bill, to submit diagnostics on an Android client (like the Shield):

Settings > Support > Submit Diagnostics > Video Player

A post was merged into an existing topic: Preventing Auto Updates?

I ran it both ways, both experienced the "stalls" watching a football game an hour or so behind while it was still recording on my Mac M2. I sent in the diagnostics right after the stalls, once using hardware and the other software. I did not try the Hybrid setting. That TV was only showing wired 100Mbits (not gigabit as I believe it should) I will have to check out where its showing the 100mb negotiation. But I would think a solid 100 Mbit Ethernet connection should be good enough for at least one 4k stream, and I am only watching at 1080p or less. -Bill

When it comes to seeking, you’d be surprised. 100mbit is not very fast for mpeg2. You would be better off using WiFi on the tv if it’s faster.

The first version of the Apple TV (HD) with an App Store only had a 100mbit Ethernet port. Back in the day, I moved it to WiFi (which felt dumb) and seeking went from some hangs, to instant. The difference was 100mbit vs 240mbit.

The link is probably correct. Most TVs, even nice Sony ones, cheap out with 100mbit Ethernet, it’s absurd.

I have been using 100 mbit connections for many years with mpg2 and never had an issue with seeking, I highly doubt that is the issue.

What do I know ¯(°_o)/¯

1 Like

Your issue is most definitely your network connection. As @maddox said, seeking relies on downloading much more than the 1x speed of a stream to give you a fluid experience. The faster your connection, the faster seeking will be.

In the case of a SHIELD that is only reporting 100mbit, that would indicate an even bigger issue, as the device is capable of gigabit, but if it's only negotiated 100mbit, it likely means that you have a wiring issue.

Replace the cable to your SHIELD and see if that increases the reported network interface rate. Once you've done that, your seeking should be much snappier.

Bill, your screenshot is showing your device connecting at full gigabit speeds and the latency and jitter look pretty good to me. Are you focusing on testing just one device and sending diagnostics?

Looks like an Internet speedtest to me (from the Shield, from the server, from another device?) -- isn't the issue in question the performance of his LAN? Specifically between the Shield and his CDVR server?

If so, and I think it is, a LAN speed test is needed.

It's built in the client to test speed between channels client and channels server

And, I see the output looks just like what he submitted -- my apologies.

Im looking into that. My best guess right now is somewhere along its route between the Mac and that Shield its auto negotiating 100 mbits, between that Mac and my older test Shield its gotten a 1 gig connection. -Bill
PS. I am wondering how Sagetv can skip those same MPEG2 files as many times as I want on that same Shield but using a different client, never seen a stall, ever. Its going to a windows pc so to even things up, I have just installed CDVR to that same PC and will record one of today's footballs games and see if that makes any difference on .

I have posted those speed tests a few times here in the past for the Devs.

I found the 100 vs 1000 issue. That shield was plugged into an AP that is only 100mbit network connections. I plugged it into the gigabit switch and its now negotiating gig speed. I will test this afternoon to see if that fixes the stall issue. Sorry for the firedrill... -Bill PS. Maybe this part of the thread, the Stalling could be moved to a seperate thread. I don't see a way for me as a user to do that.

JFYI. The change from 100 to 1000 mbit fixed the Stalling problem. I was able to watch a couple of the playoff games yesterday and could skip the 8-15 times required sometime to get past the long commercials and other BS they tend to have during football games. Maybe someday I will mirror that port and run wireshark against it during prolonged skips to see what the heck its really doing. But that probably won't happen.. -Bill Problem Solved.