Disable Deinterlacer? Flickering image

Is there a way to fully disable the Deinterlacer?

I see an option in Settings, Playback, Advanced, "Deinterlacing Mode": Hardware, Linear(60fps), Blend(30fps).

My issues are that when playing back content in Channels DVR on my new Samsung QN90C 43in tv, (using Apple TV 4K 2022) there is excessive flicking.
Alot in animated content with shading/banding most noticeable, but also with busy backgrounds...its kinda random but that is the most often. Bluey on Disney channel (TVE) it is very strong and is like strobeing effect.

Playing back recordings of the same show, in Infuse Pro, or Plex app, no flickering.

When i change this Interlacer setting to Linear or Blend, no flicking in Channels. But the picture is overall, softer looking.
(or change the Video driver to Legacy)

Is TVE supposed to be Progressive content? Or does it vary?

Why i wonder if a way to force disable Deinterlacer or force Progressive processing may affect things.

And yes, i have fiddled with all the Picture settings on the tv, including "Noise Reduction" and it helps on some flicking, but then not at all others.

TVE doesn't use deinterlacing it's all progressive

2 Likes

so... why then does the stats have a line for deinterlacer and the picture changes when i change it to something else other than Hardware?

Some TVE feeds just look like cr*p. Remember NickJr?

When they re-encode video to 30fps and try to squeeze it in a low bandwidth stream, they make tradeoffs with the encoder settings that results in display artifacts. Just like fast moving sports look like cr*p at 30fps.

What might look like interlaced content to you is actually display artifacts due to poorly re-encoded video crammed into a low bitrate 30fps stream.

There is no way to display the content the encoder threw out. It's no longer there.

Sure. But this is not that. Since it only does this on this tv, in Channels. On other tvs, does not flicker. The recordings played back outside of Channels do not fllicker. This my first Mini-LED type tv....

I don't use an Apple TV, but there have been many posts from users with recommended settings when using one attached to a 4k TV. You should also turn off all the "Marketing bullet point" enhancements on your TV and do a basic calibration on it.

Agree... set the tv to sdr and on ATV turn on match range and content. Then turn off anything on the TV that "helps" the picture. I almost returned a samsung tv becuase the picture was horrible.

2 Likes

Not anything to due with the TV settings... or Apple TV settings.
Like i said already, its only in Channels that its happening.
Picture looks great otherwise, in Channels and other apps on the Apple TV.

And other posts i found around the net that mention flicking they say is the Deinterlacer being used.

I don't use HDR...

Match Content/Frame Rate does not seem to affect Channels DVR app at all.

When enabled, i notice a black screen for 2-3 secs before any video will play in Infuse.
Does not do this in Channels.

I notice zero change when i also enable match Dynamic Range. (that only for detecting HDR content it seems)

I was running the Apple Tv on a 2K (1440P) monitor before with no issues.

Doesn’t seem like match content is working in channels DVR app at all. The TV still reports 60hz. Even when I tune to channels that are reported as 30 FPS According to to the stats. There is also is no 2 to 3 second black screen pause, like there is in other apps Which I have confirmed playing 24, 30 FPS, even 50 FPS the TV reports a change to that rate in other apps.

The setting is enabled in the Channels DVR app settings as well

2 Likes

After watching one of these things you expect to change the TV mode, please submit diagnostics.

I just submitted diags from the app after switching to a few different channels. They report 30fps in the Stats overlay, but the tv still is in 60fps mode. Odd thing though, sometimes, i do see a moment of black screen when changing channels, but it is much shorter than when Infuse triggers fps change and the tv still says it is in 60fps when this happends in Channels.

TvOS 17.3 app beta 1.29.1832

here are some quick pics i took of the screen yesterday with stats up and the info bar of the tv. are tve or .m3u channels

a 4k channel

just now

There's no value in ever changing the refresh rate if the current refresh rate is divisible by the content frame rate. It would cause disruption for no visible difference in the presentation.

You'll see if your TV is at 60hz and you play 24fps or 25fps content, it will mode switch.

1 Like

I don't think there is any content in OTA, TVE or m3u custom that is at those rates though. All stations i have checked are 30fps or 60. (or 29.xxx or 59.xxx).

And it is doing something, like i mention, it is causing a black screen when i tune a channel now. 30fps channel has a black screen before it plays. Like it lost the input for a sec. Also when you stop playback . Turn off that Match settings, no black screen. tv stays in 60 reguardless. So, seem the setting is useless (to me) since no content i can find that is not a user library import file (like a movie rip).

Infuse changes regardless. It does it at 30 fps even.

According to Apple the ATV will match change the out put signal to match at 60, 50, 30, 25 and 24fps

The tv itself is native 120hz. But the Apple TV only supports 60hz output. The Nvidia Shield supports 120hz output though.

I managed to capture video with my phone of the flicking i am having... it is a bit over exaggerated in the video, and it looks much greyer and noise in the picture, to the camera, the image does not look that bad in person, but this is the flickering that happens in Channels with this tv. Turn on Linear deinterlacer, and the flickering is gone.

link

here is more clips, notice the background flickering
link2

link 3

So far, the settings Match Content either in Channels or the ATV settings does not affect this. The channel in the vid is 30fps stream.
Only changing the Deinterlacer affects this.

@eric @tmm1

Here is another test sample. Again, more extreme case...

The ONLY setting i am changing in Channels DVR is the Deinterlacer.

Hardware Deinterlacer (Default)

Linear (60fps)


This is the same clip played back in Infuse Pro app. (which has not settings to change deinterlacer)

Infuse does have options to change Deinterlacer, in its drop down top bar while playing content... does not show up when playing CDVR recordings, but does for some movie rips, but, the files are progressive, so, i don't know what triggers it showing the option to change it.

Anyways, Infuse Pro supports these:

Auto
Efficient (Linear)
High Quality (Yadif)
Film (IVTC)
Off

I guess Yadif is considered higher quality than Linear, i also see comments elsewhere of a Yadif (2x) version as well.

I am not certain as to what Film IVTC is for, may be that is specific for 24fps films?

So, if Channels is using actual Hardware deinterlacer, an option not seemingly present with Infuse, i can only assume that Infuse is using when on Auto, Linear or Yadif, since i am not seeing the flicking with Infuse, and the picture looks the same in Channels as it does in Infuse, when i change Deinterlacer to Linear in Channels.

Try changing chroma 4:2:2 in appletv. I had issues with it on mine and it cleared up a bunch of issues.

I only ever use 4:4:4. There is no option for 4:2:2... only 4:2:0.

Only other option is 4:2:0. and i just tried that. No change with the flickering in Channels.
My tv supports hdmi 2.1 and so do my cables.
It can do 4K 144hz no issues as well.