DIY/Magnolia channel getting error 403: Not permitted to watch. (access.denied.missingpackage)

2022/04/25 15:09:57.657416 [TVE] action=science_stream error={[{access.denied.missingpackage Not permitted to watch. 403}] {{[]}}}
2022/04/25 15:09:57.671163 [ERR] Failed to start stream on channel 6108 via TVE-Comcast_SSO: TVE: 403: Not permitted to watch. (access.denied.missingpackage)
2022/04/25 15:09:57.671220 [DVR] Error running job 1650924001-ch6108 Canary DIY Recording: could not start stream on channels=[6108]: TVE: 403: Not permitted to watch. (access.denied.missingpackage)

Xfinity provider
DVR at latest pre-release v2022.04.21.1658
Noticed the error in the log from a failed recording today.
Tried watching the channel live and got the same error.
Did an individual rescan of Science and DIY/Magnolia channels and it works now, even though they didn't display errors in rescan channels.

Diagnostics submitted as 0a9ae31b-d0e4-4204-89ec-9e85512e99d3

Not sure if you can see this in the diagnostics submitted.
I had removed and re-added the Xfinity TVE source on 4/10.
7 days later on 4/17 Channels DVR automatically re-authed the DIY/Magnolia channel.
8 days after that (today) it failed (but appeared to re-auth in the logs).
2022/04/25 15:00:18.072649 [TVE] action=authed

Is your Xfinity login that you're using the one that is tied to your Xfinity internet access?

No, I'm using a secondary VIEWER only account for Channels DVR.

We've deployed a change that hopefully will resolve the situation you saw.

Thank You, just saw that and grabbed the new version.
Will reply to this thread if it happens again.