Download Speed

When I run the Speedtest app on my device, I get between 300-700mbps download speeds. However, when I have my Channels app pointed at my DVR over the local network (configured "At Home") and I want to download a show for local playback later, The Channels app reports a ~13mpbs download speed.

(My DVR is a Synology DS220+ connected to a gigabit switch and I've tried the app connected via ethernet and 5GHz wifi with the same low download speed.)

When you run speed test on your Channels you get 300-700mbps (37-87MBPS)

When on your laptop you get 13 MBPS or 13mbps. If lower case, yes thats really slow. Is your laptop connected to wifi or ethernet. Is it a older laptop with 100mbit or 1000mbit connection. Is laptop using hard drive or SSD?

If you try to manually transfer files to your server (not using channels downloads) do you get faster speed? If you getvthe same speed when manually transferimg files then the issue is your network connection. If you get faster speeds when manually transfers files then it might be channels.

Basic network trouble shooting
Restart PC
Restart router
Move ethernet cable to different port
Change ethernet canle
Restart your network adapter
Scan for malware/virus
Disconect from VPN
Stop using wifi
Are there other services, programs running on laptop or server utilizing the disk?

1 Like

Sorry I was not clear.

On the client, an M2 MacBook Air with a 2TB SSD, I can run Speedtest and consistently achieve download speeds of 700mbps over wifi and 350 over Ethernet*. On that same client, running the channels app, it’s reporting a download rrate of 11-13 regardless of client connection.

*the slower Ethernet speed is a factor of the Ethernet adapter being connected via my USB-C monitor and the monitor acting as a USB2 hub for the Ethernet adapter. More of a convenience thing. With the adapter directly connected to the MB Air, I can virtually gigabit speeds.

My point is that I don’t think this is a networking issue between the two devices.

Assuming the channels client is reporting “MBPS” it’s still 50% or less of the speed I’d expect to see, right?

The client app is the iPad version of Channels.

I think the issue is that the ios client isn't directly supported on the m1. It's more of a "it kind of works ok" situation.

BTW you might want to go usbc to a dock and then hang your monitor and ethernet off of that. Instead of downshifting to usb2 on the monitors hub. Unrelated to your issue of course...

The download UI is listing download speeds in megabytes, so you’ll want to multiply by 8 to get bits.

I’ve seen speeds as high as 50MB/s downloading on my iPad if I’m close to the Access Point, but it’s often slower depending on where I am in the house and what other activity is going on on the network.

If the speeds are slower, it could also be impacted by the DVR disk speed and if it is doing anything else at the sane time. The read rate of disks is much slower if it is also doing other writes.