Dropping frames on ATV HD since 14.5 Update

Hello, I am dropping frames like crazy using TV Everywhere on an AppleTV HD (Not 4K).
I am watching CNBC via DirecTV TV Everywhere and I show in the stats:

Dropped Frames: 0 (Decoder) 3922 (output) — and of course the output number is rising constantly.

Anyone else experiencing this? Any suggested fixes?

Attached screenshot:

Try the experimental video driver under Settings > Playback > Advanced ?

1 Like

@tmm1 - thank you. Just tried and its better, but still dropping a pretty substantial number of frames.

I found the best results with experimental video driver and default audio driver — but again, it's still dropping a lot of frames (just not as much as with the standard video driver).

Any more information I can provide?
Thanks!

How about if you use Blend or Experimental for the deinterlacer?

We've seen this happen in the past with major OS updates where older devices are much slower. Usually they track it down and fix it in the .1 release.

1 Like

You're right. Looks like as I continue to tweak and test with those settings it gets better and better. A reboot of the AppleTV after moving to the experimental video driver helped a lot too.

Thank you!!! Marking this as solved. :white_check_mark:

1 Like

How did you get that info on dropped frames?

Or put more precisely: How did you get that data overlay showing in your picture of your TV screen?

Thanks!

Swipe down while watching TV. Scroll to the right to Options and select Show Stats.

1 Like

I’m having the same issue on my Apple TV HD. I have tried restarting and changing my video, audio, and deinterlacer but still dropping tons of frames. Is this more of an issue on 14.5 because I wasn’t having an issue before?

We were getting only the occasional dropped frame (like 19 over several minutes) on our ATV 4K. I tried the experimental deinterlacer, anyway. Dropped the dropped frame rate to about 1/4 of that.

My ATV 4K’s are fine, it’s the “HD” (older) ATV’s that are dropping a LOT of frames. Totally unwatchable at times.

I’m seeing the same on an “HD” model. I’ll try out some of the advanced settings when I get a chance, but at the moment some recordings are unwatchable.

Using the experimental video driver and the experimental audio driver seemed to be better in a quick test last night. I couldn't find an option for an experimental deinterlacer as mentioned by @tmm1 above (in Dropping frames on ATV HD since 14.5 Update), and I haven't tried Blend yet.